您的位置:首页 > 其它

ZOJ1295 Reverse Text

2013-08-17 21:51 232 查看
Reverse Text
Time Limit: 2 Seconds      Memory Limit: 65536 KB
In most languages, text is written from left to right. However, there are other languages where text is read and written from right to left. As a first step towards a program that
automatically translates from a left-to-right language into a right-to-left language and back, you are to write a program that changes the direction of a given text.



Input Specification

The input contains several test cases. The first line contains an integer specifying the number of test cases. Each test case consists of a single line of text which contains at most
70 characters. However, the newline character at the end of each line is not considered to be part of the line.

Output Specification
For each test case, print a line containing the characters of the input line in reverse order.

Sample Input
3

Frankly, I don't think we'll make much

money out of this scheme.

madam I'm adam

Sample Output

hcum ekam ll'ew kniht t'nod I ,ylknarF

.emehcs siht fo tuo yenom

mada m'I madam

这题的大意就是对于每串字符串按照倒序输出即可。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int main() {
char s[100];
int Case;
cin >> Case;
getchar();
while (Case--) {
memset(s,0,sizeof(s));
gets(s);
int len = strlen(s);
for (int i = len-1; i >= 0; i--)
cout << s[i];
cout << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ZOJ 算法