您的位置:首页 > 其它

UVa401 Palindromes

2013-08-17 20:14 316 查看


  Palindromes 
A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read
from left to right as when the string is read from right to left.

A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string "3AIAE" is a mirrored
string because "A" and "I"are their own reverses, and "3" and "E" are each others' reverses.

A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string"ATOYOTA" is a mirrored palindrome because if the string is read backwards, the string is the same as the original and
because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string. Of course, "A","T", "O", and "Y" are all their own reverses.

A list of all valid characters and their reverses is as follows.

CharacterReverseCharacterReverseCharacterReverse
AAMMYY
B N Z5
C OO11
D P 2S
E3Q 3E
F R 4 
G S25Z
HHTT6 
IIUU7 
JLVV88
K WW9 
LJXX  
Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.

Input 

Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end
of file.

Output 

For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.

STRINGCRITERIA
" -- is not a palindrome."if the string is not a palindrome and is not a mirrored string
" -- is a regular palindrome."if the string is a palindrome and is not a mirrored string
" -- is a mirrored string."if the string is not a palindrome and is a mirrored string
" -- is a mirrored palindrome."if the string is a palindrome and is a mirrored string
Note that the output line is to include the -'s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.
In addition, after each output line, you must print an empty line.

Sample Input 

NOTAPALINDROME
ISAPALINILAPASI
2A3MEAS
ATOYOTA


Sample Output 

NOTAPALINDROME -- is not a palindrome.

ISAPALINILAPASI -- is a regular palindrome.

2A3MEAS -- is a mirrored string.

ATOYOTA -- is a mirrored palindrome.


Miguel Revilla 2001-04-16

这题的大意就是判定一串字符是否为回文以及镜像字符串,这两种分开来判断,对于是否回文直接定义两个标记,从两端不断比较到中间,若全都相等即为回文,而对于镜像,则是将一半字母数字与其对应的字符相转换,再进行回文比对,同时要注意单字符个数为奇数是中间的字符的镜像必须为其本身,否则便为非镜像,此外,字符转换是若当前字符无对应镜像是也可直接返回非镜像。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cctype>
using namespace std;

const char letter[27] = {"A 3 HIL JM O 2TUVWXY5"};
const char digit[11] = {"01SE Z 8 "};
const int N = 30;

bool isPalindrome(char *str,int len) {
for (int i = 0,j = len-1; i <= j; i++,j--)
if (str[i] != str[j])
return false;
return true;
}

bool isMirrored(char *str,int len) {
if (len % 2) {
if (isupper(str[len/2]) && letter[str[len/2]-'A'] == ' ')
return false;
else if (isdigit(str[len/2]) && digit[str[len/2]-'0'] == ' ')
return false;
}
for (int i = 0; i < len/2; i++) {
if (isupper(str[i]))
str[i] = letter[str[i]-'A'];
else if (isdigit(str[i]))
str[i] = digit[str[i]-'0'];
}
return isPalindrome(str,len);
}

int main() {
char str
;
bool p;
bool m;
while (cin >> str) {
int len = strlen(str);
cout << str;
p = isPalindrome(str,len);
m = isMirrored(str,len);
if (p)
if (m)
cout << " -- is a mirrored palindrome." << endl;
else
cout << " -- is a regular palindrome." << endl;
else
if (m)
cout << " -- is a mirrored string." << endl;
else
cout << " -- is not a palindrome." << endl;
cout << endl;
memset(str,0,sizeof(str));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  uva 算法