您的位置:首页 > 其它

HDU 1162 Eddy's picture MST(基础)

2013-08-17 19:54 453 查看
点击打开链接
 

Eddy's picture

[b]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5539    Accepted Submission(s): 2776
[/b]

[align=left]Problem Description[/align]
Eddy begins to like  painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room,  and he usually  puts out his newest pictures to let his friends appreciate. but the result
it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting  pictures ,so Eddy creates a problem for the his friends of you.

Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally  to link in the same place. How many distants does your duty discover the shortest length
which the ink draws?

 

 
[align=left]Input[/align]
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.

 

 
[align=left]Output[/align]
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.

 

 
[align=left]Sample Input[/align]

3
1.0 1.0
2.0 2.0
2.0 4.0

 

 
[align=left]Sample Output[/align]

3.41

 

 
[align=left]Author[/align]
eddy
 

 
[align=left]Recommend[/align]
JGShining
 
 
最小生成树简单题。
 
#include<stdio.h>
#include<string.h>
#include<math.h>
#define inf 0x3f3f3f
double g[107][107];
double x[107],y[107],pri[107];
bool vis[107];
int n;

void prime()
{
int id;
double minn,count=0;
memset(vis,false,sizeof(vis));
for(int i=1; i<=n; i++)
pri[i]=g[1][i];
vis[1]=true;
for(int i=2; i<=n; i++)
{
minn=inf;
for(int j=2; j<=n; j++)
if(minn>pri[j]&&!vis[j])
{
minn=pri[j];
id=j;
}
vis[id]=true;
count+=minn;
for(int j=2; j<=n; j++)
if(!vis[j]&&pri[j]>g[j][id])
pri[j]=g[j][id];
}
printf("%.2f\n",count);
}

int main()
{
while(scanf("%d",&n)!=EOF)
{
for(int i=1; i<=n; i++)
scanf("%lf%lf",&x[i],&y[i]);
for(int i=1; i<=n; i++)
for(int j=1; j<=n; j++)
{
double tmp_x,tmp_y,tmp;
tmp_x=(x[j]-x[i])*(x[j]-x[i]);
tmp_y=(y[j]-y[i])*(y[j]-y[i]);
tmp=sqrt(tmp_x+tmp_y);
g[i][j]=g[j][i]=tmp;
//printf("aaaffh%lf\n",tmp);
}
prime();
}

return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: