您的位置:首页 > 其它

单链表中重复元素的删除

2013-08-17 15:35 295 查看

数据结构实验之链表七:单链表中重复元素的删除

Time Limit: 1000MS Memory limit: 65536K

题目描述

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

输入

第一行输入元素个数n;
第二行输入n个整数。

输出

第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。

示例输入

10
21 30 14 55 32 63 11 30 55 30


示例输出

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21


#include<stdio.h>
#include<stdlib.h>
struct vode
{
int date;
struct vode *next;
};
int main()
{
struct vode *head,*p,*q,*p1;
head=(struct vode *)malloc(sizeof(struct vode ));
head->next=NULL;
int n,i;
scanf("%d",&n);
for(i=1;i<=n;i++)
{
p=(struct vode *)malloc(sizeof(struct vode ));
p->next=NULL;
scanf("%d",&p->date);
p->next=head->next;
head->next=p;
}
printf("%d\n",n);
p=head->next;
int k=0;
while(p)
{
if(k==0)
{
printf("%d",p->date);
k=1;
}
else printf(" %d",p->date);
p=p->next;
}
printf("\n");
p=head->next;
int sum=0;
while(p)
{
p1=p;
q=p1->next;
while(q)
{
if(p->date==q->date)
{
q=q->next;
p1->next=q;
sum++;
}
else
{
p1=p1->next;
q=q->next;
}
}
p=p->next;
}
printf("%d\n",n-sum);
p=head->next;
k=0;
while(p)
{
if(k==0)
{
printf("%d",p->date);
k=1;
}
else printf(" %d",p->date);
p=p->next;
}
printf("\n");
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: