您的位置:首页 > 运维架构

POJ 2115 C Looooops 扩展欧几里得

2013-08-17 09:58 381 查看
C Looooops

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 15066Accepted: 3820
Description

A Compiler Mystery: We are given a C-language style for loop of type

for (variable = A; variable != B; variable += C)
statement;


I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k.

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop.

The input is finished by a line containing four zeros.
Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.
Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER

Source

CTU Open 2004

/*
题意:
(A+Cx)%2^k=B ==> A+Cx = 2^k*y+B
==> Cx-2^k*y=B-A;
形如 ax+by=c
a=C
b=2^k
c=B-A;

*/

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;

__int64 f[33];
void make_hxl()
{
int i;
f[0]=1;
f[1]=2;
for(i=2;i<=32;i++)
f[i]=f[i-1]*2;
}

__int64 Ex_gcd(__int64 a,__int64 b,__int64 &x,__int64 &y)
{
if(b==0)
{
x=1;
y=0;
return a;
}
__int64 g=Ex_gcd(b,a%b,x,y);
__int64 hxl=x-(a/b)*y;
x=y;
y=hxl;
return g;
}

void make_ini(__int64 A,__int64 B,__int64 C,__int64 k)
{
__int64 c,a,b,x,y,d;
a=C;
b=f[k];
c=B-A;

d=Ex_gcd(a,b,x,y);
if(c%d!=0)
{
printf("FOREVER\n");
return;
}
x=c/d*x;
b=b/d;
x=(x%b+b)%b;
printf("%I64d\n",x);
}
int main()
{
__int64 A,B,C,k;
make_hxl();
while(scanf("%I64d%I64d%I64d%I64d",&A,&B,&C,&k)>0)
{
if(A==0 && B==0 && C==0 &&k==0)
break;
make_ini(A,B,C,k);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: