您的位置:首页 > 其它

TOJ 1752 POJ 2255 Tree Recovery

2013-08-16 21:12 477 查看

Tree Recovery

时间限制(普通/Java):1000MS/10000MS 运行内存限制:65536KByte



描述

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.

This is an example of one of her creations:

D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F




To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is
DBACEGF and the inorder traversal is ABCDEFG.

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.

However, doing the reconstruction by hand, soon turned out to be tedious.

So now she asks you to write a program that does the job for her!

输入

The input will contain one or more test cases.

Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)

Input is terminated by end of file.

输出

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

样例输入

DBACEGF ABCDEFG
BCAD CBAD


样例输出

ACBFGED
CDAB


对于给出先序和中序 后序遍历是唯一的 看上面图图和第一组数据 先序第一个字母是D 在中序中找到D 然后D的左边是左子树 右边是右子树
然后可以可以一层一层递归下去
#include<stdio.h>
#include<string.h>
char a[33],b[33];
int l;
void dfs(int x1,int y1,int x2,int y2)
{
	if(x2>y2)
		return;
	int i,ll;
	for(i=x1;i<=y1;i++)
	{
		if(a[i]==b[x2])
			break;
	}
	ll=i-x1;
	dfs(x1,i-1,x2+1,x2+ll);
	dfs(i+1,y1,x2+ll+1,y2);
	printf("%c",b[x2]);
}
main()
{
	while(scanf("%s %s",b,a)!=EOF)
	{
		l=strlen(a);
		dfs(0,l-1,0,l-1);
		puts("");
	}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: