您的位置:首页 > 其它

hdu 4565 So Easy!

2013-08-16 16:12 253 查看






Where a, b, n, m are positive integers.┌x┐is the ceil of x. For example, ┌3.14┐=4. You are to calculate Sn.

  You, a top coder, say: So easy! 



 

Input

  There are several test cases, each test case in one line contains four positive integers: a, b, n, m. Where 0< a, m < 215, (a-1)2< b < a2, 0 < b, n < 231.The input will finish with the end of file.

 

Output

  For each the case, output an integer Sn.

 

Sample Input

2 3 1 2013
2 3 2 2013
2 2 1 2013

 

Sample Output

4
14
4题目分析: 题目要

求这个得值但是取模前有更号,所以无法直接计算,我们发现0< a, m < 215, (a-1)2< b < a2, 0 < b, n < 231所以 0 <a+sqrt( b ) < 1可得表达式:

,由二项式展开可知等号右边一坨是整数并且加的数小于一,所以等式成立
然后我们设 Kn 为为等号的左边,将表达式化为递推形式后,再利用矩阵连乘来解决 Kn 的问题转化过程就是移两次项,每次都将指数约去即可化简


# include<iostream>
# include<cstdio>
# include<cstring>
typedef __int64 ll;
using namespace std;
ll n,m,a,b;
struct node
{
ll x[2][2];
} op;
node cheng(node a,node b)
{
node t;
int i,j,k;
for (i=0;i<2;i++)
for (j=0;j<2;j++)
{
ll sum=0;
for (k=0;k<2;k++)
sum=(sum+(ll)a.x[i][k]*b.x[k][j])%m;
t.x[i][j]=sum;
}
return t;
}
int main()
{
while (~scanf("%I64d%I64d%I64d%I64d",&a,&b,&n,&m))
{
ll x,y;
x=(2*a)%m; y=(2*(a*a+b))%m;
op.x[0][0]=(2*a)%m; op.x[0][1]=1;
op.x[1][0]=((b-a*a%m)+m)%m;//不要掉了这里的+m
op.x[1][1]=0;
if (n==1) { printf("%I64d\n",x); continue;};
if (n==2) { printf("%I64d\n",y); continue;};
node ans;
ans=op;
n=n-3;
while (n)
{
if (n&1) op=cheng(op,ans);
ans=cheng(ans,ans);
n=n/2;
}
printf("%I64d\n",(op.x[0][0]*y+op.x[1][0]*x)%m);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数学+矩阵