您的位置:首页 > 其它

HDU 1708 Fibonacci String

2013-08-16 11:17 197 查看
After little Jim learned Fibonacci Number in the class , he was very interest in it.

Now he is thinking about a new thing -- Fibonacci String .

He defines : str
= str[n-1] + str[n-2] ( n > 1 )

He is so crazying that if someone gives him two strings str[0] and str[1], he will calculate the str[2],str[3],str[4] , str[5]....

For example :

If str[0] = "ab"; str[1] = "bc";

he will get the result , str[2]="abbc", str[3]="bcabbc" , str[4]="abbcbcabbc" …………;

As the string is too long ,Jim can't write down all the strings in paper. So he just want to know how many times each letter appears in Kth Fibonacci String . Can you help him ?

[align=left]Input[/align]
The first line contains a integer N which indicates the number of test cases.

Then N cases follow.

In each case,there are two strings str[0], str[1] and a integer K (0 <= K < 50) which are separated by a blank.

The string in the input will only contains less than 30 low-case letters.

[align=left]Output[/align]
For each case,you should count how many times each letter appears in the Kth Fibonacci String and print out them in the format "X:N".

If you still have some questions, look the sample output carefully.

Please output a blank line after each test case.

To make the problem easier, you can assume the result will in the range of int.

[align=left]Sample Input[/align]

1
ab bc 3

[align=left]Sample Output[/align]

a:1
b:3
c:2
d:0
e:0
f:0
g:0
h:0
i:0
j:0
k:0
l:0
m:0
n:0
o:0
p:0
q:0
r:0
s:0
t:0
u:0
v:0
w:0
x:0
y:0
z:0
题意很明白:思路见代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int main()
{
int t;
char s1[50],s2[50],s;
int a[100],b[100],c[100];
int len1,len2,f;
int n,i,j;
scanf("%d",&t);
while(t--)
{
memset(s1,0,sizeof(s1));
memset(s2,0,sizeof(s2));
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
memset(c,0,sizeof(c));
scanf("%s%s%d",s1,s2,&n);
len1=strlen(s1);
len2=strlen(s2);
for(i=0; i<len1+len2; i++)
{
if(s1[i]!='\0')
{
a[s1[i]-97]++;
// b[s2[i]-96]++;
}
if(s2[i]!='\0')
{
b[s2[i]-97]++;
}
}
f=1;
for(i=2; i<=n; i++)
{
for(j=0; j<26; j++)
{
c[j]=a[j]+b[j];
}
if(f==1)
{
for(j=0; j<26; j++)
{
a[j]=c[j];
}
f=0;
}
else
{
for(j=0; j<26; j++)
{
b[j]=c[j];
}
f=1;
}
}
s='a';
if(n==0)
{
for(i=0; i<26; i++)
{
printf("%c:%d\n",s++,a[i]);
}
printf("\n");
continue;
}
if(n==1)
{
for(i=0; i<26; i++)
{
printf("%c:%d\n",s++,b[i]);
}
printf("\n");
continue;
}
for(i=0; i<26; i++)
{
printf("%c:%d",s++,c[i]);
printf("\n");
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: