您的位置:首页 > 其它

hdu 题目1253 胜利大逃亡(BFS)

2013-08-15 22:01 465 查看

胜利大逃亡

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 21968    Accepted Submission(s): 8603


[align=left]Problem Description[/align]
 

Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.



 

 

[align=left]Input[/align]
 

输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.

 

 

[align=left]Output[/align]
 

对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

 

 

[align=left]Sample Input[/align]
 

1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0

 

 

[align=left]Sample Output[/align]
 

11

 

 

 

题没话说,BFS

没听题目说得真是后悔啊,超时了好多次,一定要用C++提交,  不能G++  ,

 

代码一: 空间换时间 

953 MS2496 KB
#include<stdio.h>
#include<queue>
#include<string.h>

using namespace std;

struct node{
int x,y,z;
int step;
friend bool operator< (node n1,node n2){
return n1.step > n2.step;
}
};
int a,b,c,T;
bool map[55][55][55];
bool vis[55][55][55];
node qu[130000];
int dir[6][3]={
{1,0,0},{-1,0,0},
{0,1,0},{0,-1,0},
{0,0,1},{0,0,-1},
};

bool ok(int x,int y,int z){
//    printf("x=%d,y=%d,z=%d,map=%d\n",x,y,z,map[x][y][z]);
if(x<0 || x>=a || y<0 || y>=b|| z<0 || z>=c || map[x][y][z]==1 || vis[x][y][z]) return 0;
return 1;
}
int bfs()
{
int i;
node cur,next;
//    queue <node> q;
int front = 0,rear = 0;
cur.x = cur.y = cur.z = cur.step = 0;
memset(vis,0,sizeof(vis));
vis[0][0][0]=1;
//    printf("a=%d,b=%d,c=%d\n",a,b,c);
qu[rear++]=cur;
while(front!=rear){
cur = qu[front++];

if(cur.step>T ) return -1;
if(cur.x==a-1 && cur.y==b-1 && cur.z==c-1 ) return cur.step;
for(i=0;i<6;i++){
//        printf("cx=%d,cy=%d,cz=%d,cte=%d\n",cur.x,cur.y,cur.z,cur.step);
next.x = cur.x + dir[i][0];
next.y = cur.y + dir[i][1];
next.z = cur.z + dir[i][2];
//    printf("i=%d,x=%d,y=%d,z=%d,di=%d,dj=%d,dk=%d\n",i,next.x,next.y,next.z,dir[i][0],dir[i][1],dir[i][2]);
if(ok(next.x,next.y,next.z) ){
next.step = cur.step +1;
map[next.x][next.y][next.z] = 1;
vis[next.x][next.y][next.z] = 1;
qu[rear++]=next;
}
}
}
return -1;
}
int main()
{
int t;
scanf("%d",&t);
while(t--){
//    memset(map,-1,sizeof(map));
scanf("%d%d%d%d",&a,&b,&c,&T);
for(int i=0;i<a;i++)
for(int j=0;j<b;j++)
for(int k=0;k<c;k++){
scanf("%d",&map[i][j][k]);
}
if(map[a-1][b-1][c-1]==1) printf("-1\n");
else    printf("%d\n",    bfs());
}
return 0;
}


代码二: 时间换空间:

1109 MS624 KB
#include<stdio.h>
#include<queue>
#include<string.h>

using namespace std;

struct node{
int x,y,z;
int step;
};
int a,b,c,T;
bool map[55][55][55];
bool vis[55][55][55];
int dir[6][3]={
{1,0,0},{-1,0,0},
{0,1,0},{0,-1,0},
{0,0,1},{0,0,-1},
};

bool ok(int x,int y,int z){
//    printf("x=%d,y=%d,z=%d,map=%d\n",x,y,z,map[x][y][z]);
if(x<0 || x>=a || y<0 || y>=b|| z<0 || z>=c || map[x][y][z]==1 || vis[x][y][z]) return 0;
return 1;
}
int bfs()
{
int i;
node cur,next;
queue <node> q;
cur.x = cur.y = cur.z = cur.step = 0;
memset(vis,0,sizeof(vis));
vis[0][0][0]=1;
//    printf("a=%d,b=%d,c=%d\n",a,b,c);
q.push(cur);
while(!q.empty()){
cur = q.front();
q.pop();
if(cur.step>T ) return -1;
if(cur.x==a-1 && cur.y==b-1 && cur.z==c-1 ) return cur.step;
for(i=0;i<6;i++){
//        printf("cx=%d,cy=%d,cz=%d,cte=%d\n",cur.x,cur.y,cur.z,cur.step);
next.x = cur.x + dir[i][0];
next.y = cur.y + dir[i][1];
next.z = cur.z + dir[i][2];
//    printf("i=%d,x=%d,y=%d,z=%d,di=%d,dj=%d,dk=%d\n",i,next.x,next.y,next.z,dir[i][0],dir[i][1],dir[i][2]);
if(ok(next.x,next.y,next.z) ){
next.step = cur.step +1;
map[next.x][next.y][next.z] = 1;
vis[next.x][next.y][next.z] = 1;
q.push(next);
}
}
}
return -1;
}
int main()
{
int t;
scanf("%d",&t);
while(t--){
//    memset(map,-1,sizeof(map));
scanf("%d%d%d%d",&a,&b,&c,&T);
for(int i=0;i<a;i++)
for(int j=0;j<b;j++)
for(int k=0;k<c;k++){
scanf("%d",&map[i][j][k]);
}
if(map[a-1][b-1][c-1]==1) printf("-1\n");
else    printf("%d\n",    bfs());
}
return 0;
}


 

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: