您的位置:首页 > 其它

HDU1700:Points on Cycle

2013-08-14 23:26 363 查看
Problem Description
There is a cycle with its center on the origin.

Now give you a point on the cycle, you are to find out the other two points on it, to maximize the sum of the distance between each other

you may assume that the radius of the cycle will not exceed 1000.


Input
There are T test cases, in each case there are 2 decimal number representing the coordinate of the given point.


Output
For each testcase you are supposed to output the coordinates of both of the unknow points by 3 decimal places of precision

Alway output the lower one first(with a smaller Y-coordinate value), if they have the same Y value output the one with a smaller X.

NOTE
when output, if the absolute difference between the coordinate values X1 and X2 is smaller than 0.0005, we assume they are equal.



Sample Input
2
1.500 2.000
563.585 1.251




Sample Output
0.982 -2.299 -2.482 0.299
-280.709 -488.704 -282.876 487.453






题意:以原点为圆心,给出圆上的一点,要求两位两点,是的这三个点的距离和最大,很容易想到这是一个等边三角形,而事实上,经过对题目给出样例的测试也证明了这确实是一个等边三角形

思路:几何水题

我们可以得到方程组

x^2+y^2 = r^2

(a-x)^2+(b-y)^2=3r^2

解方程组得到的两点即为三角形的另外两点



#include <stdio.h>
#include <math.h>

int main()
{
    int t;
    double x,y,x2,y2,r;
    double ax,ay,bx,by,k,m,l,A,B,C;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf",&x,&y);
        r = x*x+y*y;
        A = r;
        B = y*r;
        C = r*r/4-r*x*x;
        ay = (-B-sqrt(B*B-4*A*C))/(2*A);
        by = (-B+sqrt(B*B-4*A*C))/(2*A);
        if(fabs(x-0)<1e-7)//防止除数出现0的情况
        {
            ax=-sqrt(r-ay*ay);
            bx=sqrt(r-by*by);
        }
        else
        {
            ax=(-r/2-ay*y)/x;//由于ay必定小于by,所以ax也必定小于bx,所以无需进行大小判定
            bx=(-r/2-by*y)/x;
        }
        printf("%.3lf %.3lf %.3lf %.3lf\n",ax,ay,bx,by);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: