您的位置:首页 > 产品设计 > UI/UE

Quicksum(poj3094,水题)

2013-08-14 20:20 281 查看
/*
http://poj.org/problem?id=3094 http://acm.hust.edu.cn/vjudge/contest/view.action?cid=28938#problem/A
A - Quicksum

Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u

Submit

Status

Practice

POJ 3094

Description

A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used for detecting transmission errors, validating document contents, and in
many other situations where it is necessary to detect undesirable changes in data.

For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and letters can occur in any combination, including
consecutive spaces.

A Quicksum is the sum of the products of each character's position in the packet times the character's value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example
Quicksum calculations for the packets "ACM" and "MID CENTRAL":

ACM: 1*1 + 2*3 + 3*13 = 46

MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12 = 650

Input

The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and contains from 1 to 255 characters.

Output

For each packet, output its Quicksum on a separate line in the output.

Sample Input

ACM

MID CENTRAL

REGIONAL PROGRAMMING CONTEST

ACN

A C M

ABC

BBC

#

Sample Output

46

650

4690

49

75

14

15

204 KB 0 ms
C++ 428 B
2013-08-11

解析:

思路:很水的题目每个字母都有一个对应值,按照输入顺序输出相应答案即可。

这里注意输入即可

*/

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
const int maxn=1000+10;
char s[maxn];
int main()
{ int i,j,sum;
while(cin.getline(s,maxn))
{
if(s[0]=='#')
break;
int sum=0;
int len=strlen(s);
// printf("%d\n",len);
for(i=0;i<len;i++)
{
if(s[i]!=' ')
{
sum+=(i+1)*(s[i]-'A'+1);
}
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: