您的位置:首页 > 其它

HDU 1072 Nightmare(BFS)

2013-08-14 16:11 459 查看

Nightmare

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5664 Accepted Submission(s): 2819


[align=left]Problem Description[/align]
Ignatius
had a nightmare last night. He found himself in a labyrinth with a time
bomb on him. The labyrinth has an exit, Ignatius should get out of the
labyrinth before the bomb explodes. The initial exploding time of the
bomb is set to 6 minutes. To prevent the bomb from exploding by shake,
Ignatius had to move slowly, that is to move from one area to the
nearest area(that is, if Ignatius stands on (x,y) now, he could only on
(x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1
minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They
could reset the exploding time to 6 minutes.

Given the layout of
the labyrinth and Ignatius' start position, please tell Ignatius
whether he could get out of the labyrinth, if he could, output the
minimum time that he has to use to find the exit of the labyrinth, else
output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2.
Each minute, Ignatius could only get to one of the nearest area, and he
should not walk out of the border, of course he could not walk on a
wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4.
If Ignatius get to the area which contains Bomb-Rest-Equipment when the
exploding time turns to 0, he can't use the equipment to reset the
bomb.
5. A Bomb-Reset-Equipment can be used as many times as you
wish, if it is needed, Ignatius can get to any areas in the labyrinth as
many times as you wish.
6. The time to reset the exploding time can
be ignore, in other words, if Ignatius get to an area which contain
Bomb-Rest-Equipment, and the exploding time is larger than 0, the
exploding time would be reset to 6.

[align=left]Input[/align]
The
input contains several test cases. The first line of the input is a
single integer T which is the number of test cases. T test cases follow.
Each
test case starts with two integers N and M(1<=N,Mm=8) which indicate
the size of the labyrinth. Then N lines follow, each line contains M
integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

[align=left]Output[/align]
For
each test case, if Ignatius can get out of the labyrinth, you should
output the minimum time he needs, else you should just output -1.

[align=left]Sample Input[/align]

3

3 3
2 1 1

1 1 0

1 1 3

4 8

2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1

1 1 1 4 1 1 1 3
5 8
1 2 1 1 1 1 1 4
1 0 0 0 1 0 0 1

1 4 1 0 1 1 0 1

1 0 0 0 0 3 0 1

1 1 4 1 1 1 1 1

[align=left]Sample Output[/align]

4

-1

13
题意:0墙,1路,2起点,3目的,4可将时间重置为6。起点开始有6s,输出到目的地最小时间。

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
int R,C;
int maze[9][9];
int vis[9][9];//用于记录走过该点最大的时间
int X[] = {-1,0,1,0};
int Y[] = {0,-1,0,1};
struct point
{
int x;
int y;
int t;//当前剩余时间
int n;//用过的总时间
};
bool Check(int x,int y,int t)
{
if(maze[x][y] == 0 || t <= 0 || vis[x][y] >= t || x < 0 || x >= R || y < 0 || y >= C)//墙,时间为0,原来该点的时间大于现在的时间
return 0;
return 1;
}
int bfs(int x,int y)
{
queue<point> Que;
int Now_x, Now_y, Now_t, Now_n;
point Q;
Q.x = x; Q.y = y; Q.t = 6; Q.n = 0;
vis[x][y] = Q.t;//标记地图时间
Que.push(Q);
while( !Que.empty() )
{
point P = Que.front();
Que.pop();
if(maze[P.x][P.y] == 3 && P.t > 0) return P.n;
for(int i=0; i<4; i++){
Q.x = P.x + X[i];
Q.y = P.y + Y[i];
Q.t = P.t - 1;
Q.n = P.n + 1;
if( Check(Q.x,Q.y,Q.t) ){
if(maze[Q.x][Q.y] == 4)Q.t = 6;//该点重置时间
vis[Q.x][Q.y] = Q.t;
Que.push(Q);
}
}
}
return 0;
}
int main()
{
//freopen("in.txt","r",stdin);
int i,j,n,start_x,start_y;
scanf("%d",&n);
while(n--)
{
cin>>R>>C;
for(i=0; i<R; i++){
for(j=0; j<C; j++){
cin>>maze[i][j];
if(maze[i][j] == 2){start_x = i;start_y = j;}
}
}
memset(vis,0,sizeof(vis));
int Flag = bfs(start_x,start_y);
if(Flag)
printf("%d\n",Flag);
else
printf("-1\n");
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: