您的位置:首页 > 其它

HDU1004——Let the Balloon Rise

2013-08-14 15:09 357 查看
Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color
and find the result.

This year, they decide to leave this lovely job to you.



Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case
letters.

A test case with N = 0 terminates the input and this test case is not to be processed.



Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.



Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0




Sample Output
red
pink



分析:map第二弹~
#include<iostream>
#include<string.h>
#include<stdio.h>
#include<ctype.h>
#include<algorithm>
#include<stack>
#include<queue>
#include<set>
#include<math.h>
#include<vector>
#include<map>
using namespace std;
int main()
{
    int n;
    string color,s;
    map<string,int>Balloon;
    while(scanf("%d",&n)&&(n!=0))
    {
        Balloon.clear();
        for(int i=0;i<n;i++)
        {
            cin>>color;
            Balloon[color]++;
        }
        int max=-1;
        map<string,int>::iterator p;
        for(p=Balloon.begin();p!=Balloon.end();p++)
        {
            if((*p).second>max)
            {
                max=(*p).second;
                s=(*p).first;
            }
        }
        cout<<s<<endl;
    }
    return 0;
}



内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: