您的位置:首页 > 其它

codevs 1206 保留两位小数

2013-08-13 18:02 375 查看
http://codevs.cn/problem/1206/

1206 保留两位小数

时间限制: 1 s

空间限制: 128000 KB

题目等级 : 青铜 Bronze

题解
查看运行结果

题目描述 Description

保留两位小数输出一个浮点数。

输入描述 Input Description

一个浮点数。double范围内

输出描述 Output Description

保留两位小数输出

样例输入 Sample Input

11

样例输出 Sample Output

11.00

数据范围及提示 Data Size & Hint

C++用 printf("%.2lf",a);

Pascal用 writeln(a:0:2);


C++和Pascal用户都请使用double类型,不要使用float,real,extended类型。

分析:

水题。

AC代码:


/*
作者:1348066599@qq.com
题目:p1206 保留两位小数
*/

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <string.h>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <list>
#include <iomanip>
#include <vector>
#pragma comment(linker, "/STACK:1024000000,1024000000")
#pragma warning(disable:4786)

using namespace std;

const int INF = 0x3f3f3f3f;
const int MAX = 10000 + 10;
const double eps = 1e-8;
const double PI = acos(-1.0);

int main()
{
double a;
while(~scanf("%lf", &a))
{
printf("%.2lf\n",a);
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: