您的位置:首页 > 编程语言 > Java开发

吃土豆_nyoj_234(动态规划).java

2013-08-13 11:46 281 查看


吃土豆

时间限制:1000 ms  |  内存限制:65535 KB
难度:4

描述Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to
eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas
are x-1 and x+1.



Now, how much qualities can you eat and then get ?

输入There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean
isn't beyond 1000, and 1<=M,N<=500.

输出For each case, you just output the MAX qualities you can eat and then get.
样例输入
4 6
11 0 7 5 13 9
78 4 81 6 22 4
1 40 9 34 16 10
11 22 0 33 39 6


样例输出
242


来源2009 Multi-University Training Contest 4

import java.util.Scanner;

public class Main{//动态规划
public static void main(String[] args) {
Scanner input=new Scanner(System.in);
while(input.hasNext()){
int n=input.nextInt();
int m=input.nextInt();
int a[][]=new int[n+3][m+3];
int []b=new int[n+3];
for(int i=3;i<n+3;i++){
for(int j=3;j<m+3;j++){
int map=input.nextInt();
a[i][j]=Math.max(a[i][j-2]+map, a[i][j-1]);//找出每行最大值
}
b[i]=a[i][m+2];
}
for(int i=3;i<n+3;i++){
b[i]=Math.max(b[i-2]+b[i], b[i-1]);//找出列最大值
}
System.out.println(b[n+2]);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息