您的位置:首页 > 其它

nyoj-234-吃土豆(动态规划)

2013-08-13 11:33 295 查看

吃土豆

时间限制:1000 ms  |  内存限制:65535 KB

难度:4

描述 Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want
to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas
are x-1 and x+1.



Now, how much qualities can you eat and then get ?

输入There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M,N<=500.
输出For each case, you just output the MAX qualities you can eat and then get.样例输入
4 6
11 0 7 5 13 9
78 4 81 6 22 4
1 40 9 34 16 10
11 22 0 33 39 6

样例输出
242

来源2009 Multi-University Training Contest 4上传者张洁烽
import java.util.Scanner;

public class Main {

/**
* @param args
*/
public static void main(String[] args) {
// TODO Auto-generated method stub
Scanner input=new Scanner(System.in);
while(input.hasNext()){
int m=input.nextInt();
int n=input.nextInt();
int[] a=new int[n+1];
int[] b=new int[m+1];
for(int i=1;i<=m;i++){
for(int j=1;j<=n;j++)
a[j]=input.nextInt();
b[i]=F(a,n);
}
System.out.println(F(b,m));
}

}

private static int F(int[] a, int n) {
// TODO Auto-generated method stub
if(n==1)
return a[1];
a[2]=Math.max(a[1], a[2]);
if(n==2)
return a[2];
for(int i=3;i<=n;i++){
a[i]+=a[i-2];
if(a[i]<a[i-1])
a[i]=a[i-1];
}
return a
;
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: