您的位置:首页 > 其它

catch that cow (bfs 搜索的实际应用,和图的邻接表的bfs遍历基本上一样)

2013-08-12 15:07 288 查看
Catch That Cow

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 38263Accepted: 11891
Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K
Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct vode
{
int time,weizhi;
};
struct vode que[100001];
int main()
{
int l,r,weizhi;
int n,k;
scanf("%d%d",&n,&k);
l=0,r=0;
weizhi=n;
que[r].weizhi=weizhi;
que[r].time=0;
r++;
int flag[100001]={0};
flag[weizhi]=1;
while(que[l].weizhi!=k)
{
weizhi=que[l].weizhi;
if(weizhi-1>=0&&weizhi-1<=100000&&flag[weizhi-1]==0)
{
que[r].weizhi=que[l].weizhi-1;
que[r].time=que[l].time+1;
flag[weizhi-1]=1;
r++;
}
if(weizhi+1>=0&&weizhi+1<=100000&&flag[weizhi+1]==0)
{
que[r].weizhi=que[l].weizhi+1;
que[r].time=que[l].time+1;
flag[weizhi+1]=1;
r++;
}
if(weizhi*2>=0&&weizhi*2<=100000&&flag[weizhi*2]==0)
{
que[r].weizhi=que[l].weizhi*2;
que[r].time=que[l].time+1;
flag[weizhi*2]=1;
r++;
}
l++;
}
printf("%d\n",que[l].time);
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: