您的位置:首页 > 其它

AC Me解题报告

2013-08-11 20:52 267 查看
题目摘要:Ignatius is doing his homework now.The teacher gives him some articles and asks him to tell how many times eachletter appears.
It's really easy, isn't it? So come on and AC ME.

题目大意:写一串字符,算出其中每个字母出现的个数。

输入输出要求

Input

Each article consists of just one line, andall the letters are in lowercase. You just have to count the number of eachletter, so do not pay attention to other characters. The length of article isat most 100000. Process to the
end of file.

Note: the problem has multi-cases, and you may use"while(gets(buf)){...}" to process to the end of file.

 

Output

For each article, you have to tell how manytimes each letter appears. The output format is like "X:N".

Output a blank line after each test case. More details in sample output.

 

输入输出样例

Sample Input

hello, this is my first acm contest!

work hard for hdu acm.

 

Sample Output

a:1

b:0

c:2

d:0

e:2

f:1

g:0

h:2

i:3

j:0

k:0

l:2

m:2

n:1

o:2

p:0

q:0

r:1

s:4

t:4

u:0

v:0

w:0

x:0

y:1

z:0

 

a:2

b:0

c:1

d:2

e:0

f:1

g:0

h:2

i:0

j:0

k:1

l:0

m:1

n:0

o:2

p:0

q:0

r:3

s:0

t:0

u:1

v:0

w:1

x:0

y:0

z:0

 

解题思路:利用ASCII码值将字符与数字相互转换,然后用循环输出结果。

代码

#include<iostream>

#include<cstring>

#include<string>

using namespace std;

int num[30]={0};

char str[100005]={'\0'};

int main()

{

   while(cin.getline(str,100005))

    {

       int i;

       char j;

       for(i=0;str[i]!='\0';i++)

       {

           if(str[i]>='a'&&str[i]<='z')

                num[str[i]-97]++;

       }

       for(i=0;i<26;i++)

       {

           j='a'+i;

           cout<<j<<":"<<num[i]<<endl;

       }

       cout<<endl;

       memset(str,'\0',sizeof(str));

       memset(num,0,sizeof(num));

    }

   return 0;

}

解题感想:本来想直接来26个if语句,但想想自己入门不是一天两天了,总不能写那么水的代码,又长又麻烦。所以巧妙利用ASCII码值来计算每个字母个数并控制输出。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  解题报告