您的位置:首页 > 编程语言 > C语言/C++

hdu 1213 How Many Tables

2013-08-11 16:22 471 查看

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 9359    Accepted Submission(s): 4619


[align=left]Problem Description[/align]
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 

[align=left]Input[/align]
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

 

[align=left]Output[/align]
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

 

[align=left]Sample Input[/align]

2
5 3
1 2
2 3
4 5

5 1
2 5

 

[align=left]Sample Output[/align]

2
4

 

题意:朋友可以和朋友或朋友的朋友坐在一起,不会和陌生人坐在一起,求需要几张桌子!(并查集)

 

AC代码

#include <iostream>
using namespace std;
int father[1111];
int find(int x)
{
if(father[x]!=x)
father[x]=find(father[x]);
return father[x];
}//查找
void Union(int a,int b)
{
a=find(a);
b=find(b);
if(a!=b)
father[a]=b;
}//并
int main()
{
int n,m,i,a,b,flag,t;
while (scanf("%d",&t)!=EOF)
{
while(t--)
{
scanf("%d",&n);
for (i=1;i<=n;i++)
father[i]=i;
scanf("%d",&m);
while(m--)
{
scanf("%d%d",&a,&b);
Union(a,b);
}
flag=0;
for (i=1;i<=n;i++)
{
if(father[i]==i)
flag++;
}
printf("%d\n",flag);//输出剩余的二叉树数
}
}
return 0;
}


谢谢阅读!
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM c++ 并查集