您的位置:首页 > 其它

HDU 1058 Humble Numbers

2013-08-11 14:09 399 查看
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence

[align=left]Input[/align]
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

[align=left]Output[/align]
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

[align=left]Sample Input[/align]

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

[align=left]Sample Output[/align]

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.
题目大意:让你找humble number(就是这个数分解质因数后,有且只能有2,3,5,7),输入一个n,找到第n个humble number数.思路:找到这么多数,存到数组中,输出。分析:The 5842nd humble number is 2000000000.暴力枚举肯定超时,枚举几万,十几万还可以。换一个思路,可以考虑枚举2,3,5,7因子数,更重要的是找到当前这个humble,怎么找到下一个。本人也是看了大牛的代码,才晓得,见AC代码。
#include<stdio.h>
int f[5843];
int min(int a,int b,int c,int d)
{
int x,y,m;
x=a>b?b:a;
y=c>d?d:c;
m=x>y?y:x;
return m;
}
int main()
{
int a,b,c,d;
int i;
int n;
a=b=c=d=1;
f[1]=1;
for(i=2; i<=5842; i++)
{
//每次找到的humble,乘以因子数,取最小的。
f[i]=min(f[a]*2,f[b]*3,f[c]*5,f[d]*7);
//一旦找到的humble是以前humble的(因子)(即2,3,5,7)倍数,该以下一个humble数因子了。如果继续以当前为因子,则最小值都不会变了。即一直重复当前humble,不再记录新的humble //
if(f[i]==2*f[a])
a++;
if(f[i]==3*f[b])
b++;
if(f[i]==5*f[c])
c++;
if(f[i]==7*f[d])
d++;
}
while(scanf("%d",&n)!=EOF&&n)
{
if(n%100==11||n%100==12||n%100==13) printf("The %dth humble number is %d.\n",n,f
);
else
{
if(n%10==1) printf("The %dst humble number is %d.\n",n,f
);
else if(n%10==2) printf("The %dnd humble number is %d.\n",n,f
);
else if(n%10==3) printf("The %drd humble number is %d.\n",n,f
);
else printf("The %dth humble number is %d.\n",n,f
);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: