您的位置:首页 > 其它

HDU1009——FatMouse' Trade

2013-08-11 13:39 411 查看
[align=left][/align]
[align=left]Problem Description[/align]
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.

The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of
cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

 

[align=left]Input[/align]
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case
is followed by two -1's. All integers are not greater than 1000.

 

[align=left]Output[/align]
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

 

[align=left]Sample Input[/align]

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

 

[align=left]Sample Output[/align]

13.333
31.500

 分析:

贪心算法——找最优解,我的思路是,运用结构体,运用sort函数将数据从大到小排序,先换: 7  2; 再换 5 2;最后用剩下的1个,换1.33的javabeen。

,然后问题就迎刃而解了。。
#include<algorithm>
#include<iostream>
#include<stdio.h>
using namespace std;//
struct node
{
int x;
int y;
double z;
}p[1005];//this is结构体
int cmp(node a,node b)
{
return a.z>b.z;
}
//不加这部分默认是从小到大排列
int main()
{
int m,n,i;
double s;
while(scanf("%d%d",&m,&n)&&(m!=-1||n!=-1))
{
s=0.0;
for(i=0; i<n; i++)
{
scanf("%d%d",&p[i].x,&p[i].y);
p[i].z=p[i].x*1.0/p[i].y;
}
sort(p,p+n,cmp);//————排序;
for(i=0; i<n; i++)
{
if(m>=p[i].y)
{
s=s+p[i].x;
m=m-p[i].y;
}
else
{
s=s+m*p[i].z;
break;
}
}

printf("%.3f\n",s);
}
return 0;
}
//OK



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: