您的位置:首页 > 其它

poj 1654 Area(计算几何)

2013-08-11 08:50 330 查看
Area

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 12974Accepted: 3682
Description

You are going to compute the area of a special kind of polygon. One vertex of the polygon is the origin of the orthogonal coordinate system. From this vertex, you may go step by step to the following vertexes of the polygon until back to the initial vertex.
For each step you may go North, West, South or East with step length of 1 unit, or go Northwest, Northeast, Southwest or Southeast with step length of square root of 2.

For example, this is a legal polygon to be computed and its area is 2.5:



Input

The first line of input is an integer t (1 <= t <= 20), the number of the test polygons. Each of the following lines contains a string composed of digits 1-9 describing how the polygon is formed by walking from the origin. Here 8, 2, 6 and 4 represent North,
South, East and West, while 9, 7, 3 and 1 denote Northeast, Northwest, Southeast and Southwest respectively. Number 5 only appears at the end of the sequence indicating the stop of walking. You may assume that the input polygon is valid which means that the
endpoint is always the start point and the sides of the polygon are not cross to each other.Each line may contain up to 1000000 digits.

Output

For each polygon, print its area on a single line.

Sample Input
4
5
825
6725
6244865


Sample Output
0
0
0.5
2


Source

POJ Monthly--2004.05.15 Liu Rujia@POJ

题意:求任意多边形面积

题解:用叉积逐个三角形求解就可以了,由于旋转方向不一定,所以面积有可能为负数,不过全部的三角形的旋转方向是一样的,所以不用担心有抵消的面积

#include<stdio.h>
#include<string.h>
struct point{
int x,y;
}p[1000010];
char s[1000010];
int way[9][2]={{1,-1},{1,0},{1,1},{0,-1},{0,0},{0,1},{-1,-1},{-1,0},{-1,1}};
long long mult(struct point p1,struct point p2,struct point p3)
{
return (long long)(p2.x-p1.x)*(p3.y-p1.y)-(long long)(p3.x-p1.x)*(p2.y-p1.y);
}
int main()
{
int t,i,temp,len;
long long res;

scanf("%d",&t);
while(scanf("%s",s)>0)
{
len=strlen(s);
res=p[0].x=p[0].y=0;
for(i=1;i<=len;i++)
{
temp=s[i-1]-'1';
p[i].x=p[i-1].x+way[temp][0];
p[i].y=p[i-1].y+way[temp][1];
}
for(i=1;i<=len;i++)
res+=mult(p[0],p[i],p[i+1]);
if(res<0) res=-res;
if(res&1) printf("%I64d.5\n",res/2);
else printf("%I64d\n",res/2);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: