您的位置:首页 > 其它

Poj 1759 (二分)

2013-08-10 21:39 239 查看
Garland

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 1184Accepted: 515
Description


The New Year garland consists of N lamps attached to a common wire that hangs down on the ends to which outermost lamps are affixed. The wire sags under the weight
of lamp in a particular way: each lamp is hanging at the height that is 1 millimeter lower than the average height of the two adjacent lamps.

The leftmost lamp in hanging at the height of A millimeters above the ground. You have to determine the lowest height B of the rightmost lamp so that no lamp in the garland lies on the ground though some of them may touch the ground.

You shall neglect the lamp's size in this problem. By numbering the lamps with integers from 1 to N and denoting the ith lamp height in millimeters as Hi we derive the following equations:

H1 = A

Hi = (Hi-1 + Hi+1)/2 - 1, for all 1 < i < N

HN = B

Hi >= 0, for all 1 <= i <= N

The sample garland with 8 lamps that is shown on the picture has A = 15 and B = 9.75.

Input
The input file consists of a single line with two numbers N and A separated by a space. N (3 <= N <= 1000) is an integer representing the number of lamps in the garland, A (10 <= A <= 1000) is a real number representing the height
of the leftmost lamp above the ground in millimeters.
Output
Write to the output file the single real number B accurate to two digits to the right of the decimal point representing the lowest possible height of the rightmost lamp.
Sample Input
692 532.81

Sample Output
446113.34

Source
Northeastern Europe 2000

这个题就是根据递推式求得每个点的高度,看是否符合题意。因为已知A,而如果二分B得话不太好求各个项的表达式,所以选择二分从左往右第三个点的值,这样就能表示出递推式得前两项,继而推得整个数列。这题又是G++过不了,改成c++才过的。真是坑爹的Poj,CF就从来没遇到过。

#include<cstdio>
#include<cstring>
#include<vector>
#include<cmath>
#include<queue>
#include<iostream>
#include<map>
using namespace std;
const int maxn = 1000 + 5;

int n;
double A;
double ans[maxn];

bool can(double x){
    ans[1] = x;
    ans[0] = (ans[1]+A)/2-1;
    if(ans[0] < 0) return false;
    for(int i = 2;i < n-1;i++){
        ans[i] = 2*(ans[i-1]+1)-ans[i-2];
        if(ans[i] < 0) return false;
    }
    return true;
}

int main(){
    while(scanf("%d%lf",&n,&A) != EOF){
        double l = 0,r = 1000;
        for(int i = 0;i < 100;i++){
            double mid = (l+r)/2;
            if(can(mid)){
                r = mid;
            }
            else {
                l = mid;
            }
        }
        printf("%.2lf\n",ans[n-2]);
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: