您的位置:首页 > 其它

poj--1611--并查集(路径压缩运用)

2013-08-10 10:30 330 查看
The Suspects

Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 18782 Accepted: 9084
Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student
is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the
number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1

 

 

#include <iostream>
#include<stdio.h>
#include<stdlib.h>
using namespace std;

const int MAXN = 30500; /*必须开大点/
int pa[MAXN];    /*p[x】表示x的父节点
int rank[MAXN];    /*rank是x的高度的一个上界/
int num[MAXN];/*num[]//存的集合中的元素个数

void make_init(int x)
{
pa[x] = x;
rank[x] = 0;
num[x] = 1;
}

int find_set(int x)
{
int r = x, temp;

while(pa[r] != r) r = pa[r];
while(x != r)
{
temp = pa[x];
pa[x] = r;
x = temp;
}
return x;
//if(x != pa[x]) //递归压缩。不太好,容易溢出栈
//    pa[x] = find_set(pa[x]);
//return pa[x];
}

void union_set(int x, int y)
{
x = find_set(x);
y = find_set(y);
if(x == y)return ;
if(rank[x] > rank[y])/*让rank比较高的作为父节点
{
pa[y] = x;
num[x] += num[y];
}
else
{
pa[x] = y;
if(rank[x] == rank[y])
rank[y]++;
num[y] += num[x];
}
}

//answer to 1611
int main()
{
int n, m, x, y, i, t, j;
while(scanf("%d%d", &n, &m))
{
if(m==n && n == 0) break;
if(m == 0)
{
printf("1\n");
continue;
}
for(i = 0; i < n; i++){
make_init(i);
}
for(i = 0; i < m; i++)
{
scanf("%d", &t);
scanf("%d", &x);
for(j = 1; j < t; j++){
scanf("%d", &y);
union_set(x, y);
x = y;
}
}
x = find_set(0);
printf("%d\n",num[x]);
}
return 0;
}

 

 

 

 

这是朴素查找的代码,适合数据量不大的情况:

int findx(int x)
{
int r=x;
while(parent[r] !=r)
r=parent[r];
return r;
}


   

    下面是采用路径压缩的方法查找元素:

int find(int x)       //查找x元素所在的集合,回溯时压缩路径
{
if (x != parent[x])
{
parent[x] = find(parent[x]);     //回溯时的压缩路径
}         //从x结点搜索到祖先结点所经过的结点都指向该祖先结点
return parent[x];
}


    

    上面是一采用递归的方式压缩路径, 但是,递归压缩路径可能会造成溢出栈,我曾经因为这个RE了n次,下面我们说一下非递归方式进行的路径压缩:

int find(int x)
{
int k, j, r;
r = x;
while(r != parent[r])     //查找跟节点
r = parent[r];      //找到跟节点,用r记录下
k = x;
while(k != r)             //非递归路径压缩操作
{
j = parent[k];         //用j暂存parent[k]的父节点
parent[k] = r;        //parent[x]指向跟节点
k = j;                    //k移到父节点
}
return r;         //返回根节点的值
}



 


                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: