您的位置:首页 > 理论基础 > 计算机网络

Triangular Sums http://acm.nyist.net/JudgeOnline/problem.php?pid=122

2013-08-09 17:57 429 查看

Triangular Sums

时间限制:3000 ms | 内存限制:65535 KB
难度:2

描述
The nth Triangular number, T(n) = 1 + … + n, is the sum of the first n integers. It is the number of points in a triangular array with n points on side. For example T(4):

[align=center]X
X X
X X X
X X X X[/align]
Write a program to compute the weighted sum of triangular numbers:

W(n) =
SUM[k = 1…n; k * T(k + 1)]


输入The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer n, (1 ≤ n ≤300), which is the number of points on a side of the triangle.输出For each dataset, output on a single line the dataset number (1 through N), a blank, the value of n for the dataset, a blank, and the weighted sum ,W(n), of triangular numbers for n.样例输入
4
3
4
5
10

样例输出
1 3 45
2 4 105
3 5 210
4 10 2145

来源Greater New York 2006

#include<stdio.h>
int main()
{
int i,n;
scanf("%d",&n);
for(i=1;i<=n;i++)
{
int k,j,m;
long int toal=0,sum=1;
scanf("%d",&m);
for(j=1;j<=m;j++)
{
sum+=j+1;
toal=toal+j*sum;
}
printf("%d %d %ld\n",i,m,toal);
}
return 0;
}


一看题估计你会蒙了,但是一看代码估计你会笑,其实此题不难,难的是理解不了题意。题意是给你一个数n,然后求出前n+1项和T(n+1),然后计算n*T(n+1);输出时注意格式就行了。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: