您的位置:首页 > 其它

POJ 2240 Arbitrage

2013-08-09 15:26 381 查看
这道题和1860有点像啊。就是求正环啊、、、但是有一点不一样的是,这个题初始化的时候要初始化为1.0不是0否则乘以利率之后就会变成零了啊、、竟然没发现啊、、这个脑子啊,进水了啊、、、、

Arbitrage

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13270 Accepted: 5585
Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French
franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear.
The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency.
Exchanges which do not appear in the table are impossible. 

Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
Sample Input
3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output
Case 1: Yes
Case 2: No

#include <stdio.h>
#include <string.h>
#include <string>
#include <stdlib.h>
#include <map>
#include <algorithm>
#include <iostream>
#define oo 1 << 30

using namespace std;

struct Edge
{
int u, v;
double w;
} edge[11100];
int n, m, t;
double d[11100];

int bellman_ford()
{
for(int i = 0; i <= n; i++) d[i] = 1.0;
//d[1] = 1.0;
for(int i = 0; i < n; i++)
for(int j = 0; j < t; j++)
if(d[edge[j].v] < d[edge[j].u]*edge[j].w)
d[edge[j].v] = d[edge[j].u]*edge[j].w;
for(int j = 0; j < t; j++)
if(d[edge[j].v] < d[edge[j].u]*edge[j].w)
return 1;
return 0;
}

int main()
{
int i;
int count = 1;
char s1[110], s2[110];
while(~scanf("%d",&n) && n)
{
map<string, int> mp;
t = 0;
string name;//现学的mp,感觉很好用啊
for(i = 1; i <= n; i++)
{
cin >>name;
mp[name] = i;
}
scanf("%d",&m);
while(m--)
{
scanf("%s %lf %s",s1, &edge[t].w, s2);
edge[t].u = mp[s1];
edge[t++].v = mp[s2];
}
int flat = bellman_ford();
printf("Case %d: ",count++);
if(flat)
printf("Yes\n");
else
printf("No\n");
}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ 最短路