您的位置:首页 > 其它

hdu 1690 Bus System 最短路 floyd

2013-08-08 23:58 337 查看

Bus System

Time
Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K
(Java/Others)

Total Submission(s): 3305 Accepted Submission(s):
822


[align=left]Problem Description[/align]
Because of the huge population of China,
public transportation is very important. Bus is an important
transportation method in traditional public transportation system.
And it’s still playing an important role even now.

The bus system of City X is quite strange. Unlike other city’s
system, the cost of ticket is calculated based on the distance
between the two stations. Here is a list which describes the
relationship between the distance and the cost.



Your neighbor is a person who is a really miser. He asked you to
help him to calculate the minimum cost between the two stations he
listed. Can you solve this problem for him?

To simplify this problem, you can assume that all the stations are
located on a straight line. We use x-coordinates to describe the
stations’ positions.

[align=left]Input[/align]
The input consists of several test
cases. There is a single number above all, the number of cases.
There are no more than 20 cases.

Each case contains eight integers on the first line, which are L1,
L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not
larger than 1,000,000,000. You can also assume that
L1<=L2<=L3<=L4.

Two integers, n and m, are given next, representing the number of
the stations and questions. Each of the next n lines contains one
integer, representing the x-coordinate of the ith station. Each of
the next m lines contains two integers, representing the start
point and the destination.

In all of the questions, the start point will be different from the
destination.

For each
case,2<=N<=100,0<=M<=500,
each x-coordinate is between -1,000,000,000 and 1,000,000,000, and
no two x-coordinates will have the same value.

[align=left]Output[/align]
For each question, if the two stations
are attainable, print the minimum cost between them. Otherwise,
print “Station X and station Y are not attainable.” Use the format
in the sample.

[align=left]Sample Input[/align]

2 1 2 3 4 1
3 5 7 4 2 1 2 3 4 1 4 4 1 1 2 3 4 1 3 5 7 4 1 1 2 3 10 1 4

[align=left]Sample Output[/align]

Case 1: The
minimum cost between station 1 and station 4 is 3. The minimum cost
between station 4 and station 1 is 3. Case 2: Station 1 and station
4 are not attainable.

 

 
代码:

 

#include<stdio.h>          

#include<string.h>

#include<stdlib.h>      

#define MAXSIZE 101  

#define INT_MAX 0x7f7f7f7f7f7f7f7fLL  // 这个值要足够大
。才能ac

   

void floyd(__int64 [][MAXSIZE], __int64 );

#define  MAXSUM(a, b) (((a) != INT_MAX
&& (b) != INT_MAX) ? ((a) + (b)) :
INT_MAX)
void
floyd(__int64 dist[][MAXSIZE], __int64 n)

{

    __int64 i,
j, k;

    for(k = 0; k
< n; k++)

      
for(i = 0; i < n; i++)

         
for(j = 0; j < n; j++)

             
if(dist[i][j] > MAXSUM(dist[i][k],
dist[k][j]))

                
dist[i][j] = MAXSUM(dist[i][k],
dist[k][j]);           

}

int main()

{

   __int64
dist[MAXSIZE][MAXSIZE],x[MAXSIZE];

   __int64
s,t,i,j,test,n,m,dis,L1,L2,L3,L4,C1,C2,C3,C4,ca;

  
scanf("%I64d",&test);

   ca=1;

   while(test--)

   {

      
scanf("%I64d%I64d%I64d%I64d%I64d%I64d%I64d%I64d",&L1,&L2,&L3,&L4,&C1,&C2,&C3,&C4);

      
scanf("%I64d%I64d",&n,&m);      

      
for(i=0;i<n;i++)

          
scanf("%I64d",&x[i]);    

      
for (i = 0; i < n-1; i++)

      
{

          
for (j = i+1; j < n; j++)

          
{

              
dis=x[i]-x[j];

              
if(dis<0)dis=-dis;

              
if(dis<=L1)dist[i][j]=dist[j][i]=C1;

              
else if(dis<=L2)dist[i][j]=dist[j][i]=C2;

              
else if(dis<=L3)dist[i][j]=dist[j][i]=C3;

              
else if(dis<=L4)dist[i][j]=dist[j][i]=C4;

              
else
dist[i][j]=dist[j][i]=INT_MAX;           
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: