您的位置:首页 > 其它

poj_1142_Smith Numbers(分解质因子)

2013-08-08 10:51 483 查看
Smith Numbers

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 11030Accepted: 3851
Description

While skimming his phone directory in 1982, Albert Wilansky, a mathematician of Lehigh University,noticed that the telephone number of his brother-in-law H. Smith had the following peculiar property: The sum of the digits of that number was equal to the sum
of the digits of the prime factors of that number. Got it? Smith's telephone number was 493-7775. This number can be written as the product of its prime factors in the following way:

4937775= 3*5*5*65837

The sum of all digits of the telephone number is 4+9+3+7+7+7+5= 42,and the sum of the digits of its prime factors is equally 3+5+5+6+5+8+3+7=42. Wilansky was so amazed by his discovery that he named this kind of numbers after his brother-in-law: Smith numbers.

As this observation is also true for every prime number, Wilansky decided later that a (simple and unsophisticated) prime number is not worth being a Smith number, so he excluded them from the definition.

Wilansky published an article about Smith numbers in the Two Year College Mathematics Journal and was able to present a whole collection of different Smith numbers: For example, 9985 is a Smith number and so is 6036. However,Wilansky was not able to find a
Smith number that was larger than the telephone number of his brother-in-law. It is your task to find Smith numbers that are larger than 4937775!
Input

The input file consists of a sequence of positive integers, one integer per line. Each integer will have at most 8 digits. The input is terminated by a line containing the number 0.
Output

For every number n > 0 in the input, you are to compute the smallest Smith number which is larger than n,and print it on a line by itself. You can assume that such a number exists.
Sample Input
4937774
0

Sample Output
4937775

Source

Mid-Central European Regional Contest 2000

题型:数论

题意:

寻找最接近并且大于给定数字的smith_number。

所谓smith_number,就是指这个数的各位上的和与这个数所有素数因子的每一位上的和相等。

for example:

4937775= 3*5*5*65837

sum1 = 4+9+3+7+7+7+5 = 42 = 3+5+5+6+5+8+3+7 = sum2;

分析:

从给定的数+1开始枚举,将这个数的所有素数因子求出来,然后枚举每一个素数因子求出sum2,再拿sum2与sum1来比较。注意,如果那个数自己本身就是素数,那么这个数就不是smith_number。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
const int maxn=10000;
int facs[maxn];
int cnt;
void find_fac(int n){
cnt=0;
for(int i=2;i*i<=n;i+=2){
while(!(n%i))
n/=i,facs[cnt++]=i;
if(i==2) --i;
}
if(n>1) facs[cnt++]=n;
}

int main(){
int n;
while(scanf("%d",&n)&&n){
for(int i=n+1;;i++){
//memset(facs,0,sizeof(facs));
find_fac(i);
if(cnt==1) continue;
else{
int t=i;
int sum1=0;
while(t){
sum1+=t%10;
t/=10;
}
int sum2=0;
for(int j=0;j<cnt;j++){
//t=facs[j];
while(facs[j]){
sum2+=facs[j]%10;
facs[j]/=10;
}
}
if(sum1==sum2){
printf("%d\n",i);
break;
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: