您的位置:首页 > 其它

poj2096(概率DP)

2013-08-07 23:16 225 查看
Collecting Bugs

Time Limit: 10000MS Memory Limit: 64000K
Total Submissions: 1656 Accepted: 744
Case Time Limit: 2000MS Special Judge
Description
Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers
exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program.

Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s
subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of
each category.

Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be
interested in Ivan's opinion about the reliability of the obsolete version.

A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems.
The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem.

Find an average time (in days of Ivan's work) required to name the program disgusting.
Input
Input file contains two integer numbers, n and s (0 < n, s <= 1 000).
Output
Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.
Sample Input
1 2

Sample Output
3.0000

Source
Northeastern Europe 2004, Northern Subregion
 
本题每天能检查到一种类型的bug,且该bug位于不同的子系统中。现有n种不同类型,s种不同子系统。保证bug的数目足够多,使得每次bug出现在每种类型、没种子系统中的概率相同分别为1/n,1/s.求找到所有类型的、出现在所有类型中的bug的期望天数。
设dp[i][j]表示找到i个不同类型,出现在j个子系统中的概率,易知dp
[s]=0.
     dp[i][j]=p1*dp[i][j]+p2*dp[i+1][j]+p3*dp[i][j+1]+p4*dp[i+1][j+1]+1
移项得
     dp[i][j]=((n-i)*jdp[i+1][j]+i*(s-j)*dp[i][j+1]+(s-j)*(n-i)*dp[i+1][j+1]+ns)/(n*s-i*j)前提的保证n*s!=i*j,这是实际问题的要求。
 
#include<iostream>
#include<cstdio>
using namespace std;

int n,s;
double dp[1000+10][1000+10];

int main()
{
int i,j;
while(~scanf("%d%d",&n,&s))
{
memset(dp,0,sizeof(dp));
for(i=n;i>=0;i--)
{
for(j=s;j>=0;j--)
{
if(n*s!=i*j)dp[i][j]=((n-i)*j*dp[i+1][j]+i*(s-j)*dp[i][j+1]+(s-j)*(n-i)*dp[i+1][j+1]+n*s)/(n*s-i*j);
}
}
printf("%.4lf\n",dp[0][0]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  动态规划