您的位置:首页 > 其它

POJ 3370 Halloween Treats

2013-08-07 20:28 309 查看
Halloween treats

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5631 Accepted: 2097 Special Judge
Description

Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts,
the children have decided they will put all sweets together and then divide them evenly among themselves. From last year's experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number
of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.

Your job is to help the children and present a solution.

Input

The input contains several test cases.

The first line of each test case contains two integers c and
n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains
n space separated integers a1 , ... ,
an
(1 ≤ ai ≤ 100000 ), where
ai represents the number of sweets the children get if they visit neighbour
i.

The last test case is followed by two zeros.

Output

For each test case output one line with the indices of the neighbours the children should select (here, index
i corresponds to neighbour i who gives a total number of
ai sweets). If there is no solution where each child gets at least one sweet print "no sweets" instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.

Sample Input
4 5
1 2 3 7 5
3 6
7 11 2 5 13 17
0 0

Sample Output
3 5
2 3 4

Source
Ulm Local 2007
 

程序如下(已AC):

#include<stdio.h>

#define M 100005

int main()

{

 int c,n,i,j,a[M],sum,b,e,k;

 while(scanf("%d%d",&c,&n),c+n)

 {

  for(i=0;i<=c;i++)

  {

   a[i]=0;

  }

  sum=0;

  b=1;

  for(i=1;i<=n;i++)

  {

   scanf("%d",&e);

   sum=(sum+e)%c;

   if(b)

   {

    if(sum==0)

    {

     j=1;

     k=i;

     b=0;

     continue;

    }

    else if(a[sum])

    {

     j=a[sum]+1;

     k=i;

     b=0;

     continue;

    }

    a[sum]=i;

   }

  }

  for(i=j;i<=k;i++)

   printf("%d%c",i,i==k?'\n':' ');

 }

 return 0;

}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: