您的位置:首页 > 其它

poj 3249 Test for Job (记忆化深搜)

2013-08-07 16:26 232 查看
http://poj.org/problem?id=3249

Test for Job

Time Limit: 5000MSMemory Limit: 65536K
Total Submissions: 8206Accepted: 1831
Description

Mr.Dog was fired by his company. In order to support his family, he must find a new job as soon as possible. Nowadays, It's hard to have a job, since there are swelling numbers of the unemployed. So some companies often use hard tests for their recruitment.

The test is like this: starting from a source-city, you may pass through some directed roads to reach another city. Each time you reach a city, you can earn some profit or pay some fee, Let this process continue until you reach a target-city. The boss will compute the expense you spent for your trip and the profit you have just obtained. Finally, he will decide whether you can be hired.

In order to get the job, Mr.Dog managed to obtain the knowledge of the net profit Vi of all cities he may reach (a negative Vi indicates that money is spent rather than gained) and the connection between cities. A city with no roads leading to it is a source-city and a city with no roads leading to other cities is a target-city. The mission of Mr.Dog is to start from a source-city and choose a route leading to a target-city through which he can get the maximum profit.

Input

The input file includes several test cases. The first line of each test case contains 2 integers n and m(1 ≤ n ≤ 100000, 0 ≤ m ≤ 1000000) indicating the number of cities and roads. The next n lines each contain a single integer. The ith line describes the net profit of the city i, Vi (0 ≤ |Vi| ≤ 20000) The next m lines each contain two integers x, y indicating that there is a road leads from city x to city y. It is guaranteed that each road appears exactly once, and there is no way to return to a previous city.
Output

The output file contains one line for each test cases, in which contains an integer indicating the maximum profit Dog is able to obtain (or the minimum expenditure to spend)
Sample Input

6 5
1
2
2
3
3
4
1 2
1 3
2 4
3 4
5 6

Sample Output

7

Hint

/**
status:Time Limit Exceeded
language:G++    codelength:1646B
author:cj
*/

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<vector>
#include<queue>
#include<string.h>

#define N  100010
#define INF 1000000000
using namespace std;

struct Nod
{
int id,sum;
}nd1,nd2;
vector<int> vct
;
int v
,in
,out
,visit
;

int bfs(int s)
{
queue<Nod> q;
nd1.id = s;
nd1.sum = v[nd1.id];

q.push(nd1);
visit[s]=1;
int maks = nd1.sum;
while(!q.empty())
{
nd2 = q.front();
q.pop();
if(!out[nd2.id]&&maks<nd2.sum)    maks = nd2.sum;
int i;
for(i=0;i<vct[nd2.id].size();i++)
{
nd1.id = vct[nd2.id][i];
nd1.sum = nd2.sum + v[nd1.id];
if(visit[nd1.id]<in[nd1.id])
{
q.push(nd1);
visit[nd1.id]++;
}
}
}
return maks;
}

int main()
{
int n,i,m;
while(~scanf("%d%d",&n,&m))
{
for(i=1;i<=n;i++)
{
scanf("%d",v+i);
vct[i].clear();
}
memset(in,0,sizeof(int)*(n+1));
memset(out,0,sizeof(int)*(n+1));
for(i=1;i<=m;i++)
{
int a,b;
scanf("%d%d",&a,&b);
out[a]++;
in[b]++;
vct[a].push_back(b);
}
int ans = 0;
for(i=1;i<=n;i++)
{
if(in[i]==0)
{
memset(visit,0,sizeof(int)*(n+1));
int temp = bfs(i);
if(ans<temp)    ans = temp;
}
}
printf("%d\n",ans);
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: