您的位置:首页 > 其它

1048. Find Coins (25)-PAT

2013-08-07 10:51 323 查看


1048. Find Coins (25)

时间限制

50 ms

内存限制

32000 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each
bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she
can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second
line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <=
V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output "No Solution" instead.
Sample Input 1:
8 15
1 2 8 7 2 4 11 15

Sample Output 1:
4 11

Sample Input 2:
7 14
1 8 7 2 4 11 15

Sample Output 2:
No Solution

推荐指数:※

来源:http://pat.zju.edu.cn/contests/pat-a-practise/1048

思想与编程之美的”2.12快速寻找满足条件的两个数“相同

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
int compare_int(const void * a, const void *b){
return (*((int*)a)-*((int *)b));

}
using namespace std;
int main(){
int low,high;
int n,m,i;
cin>>n>>m;
int *coins=new int
;
for(i=0;i<n;i++)
cin>>coins[i];
qsort(coins,n,sizeof(int),compare_int);
low=0;high=n-1;
do{
int tmp=coins[low]+coins[high];
if(tmp==m){
cout<<coins[low]<<" "<<coins[high]<<endl;
break;
}
else if(tmp>m)
high--;
else
low++;
}while(low<=high-1);
if(low>high-1)
cout<<"No Solution"<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: