您的位置:首页 > 其它

Children of the Candy Corn (bfs+dfs)

2013-08-07 10:37 316 查看
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 8120Accepted: 3547
DescriptionThe cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find the exit.One popular maze-walking strategy guarantees that the visitor will eventually find the exit. Simply choose either the right or left wall, and follow it. Of course, there's no guarantee which strategy (left or right) will be better, and the path taken is seldom the most efficient. (It also doesn't work on mazes with exits that are not on the edge; those types of mazes are not represented in this problem.)As the proprieter of a cornfield that is about to be converted into a maze, you'd like to have a computer program that can determine the left and right-hand paths along with the shortest path so that you can figure out which layout has the best chance of confounding visitors.
InputInput to this problem will begin with a line containing a single integer n indicating the number of mazes. Each maze will consist of one line with a width, w, and height, h (3 <= w, h <= 40), followed by h lines of w characters each that represent the maze layout. Walls are represented by hash marks ('#'), empty space by periods ('.'), the start by an 'S' and the exit by an 'E'.Exactly one 'S' and one 'E' will be present in the maze, and they will always be located along one of the maze edges and never in a corner. The maze will be fully enclosed by walls ('#'), with the only openings being the 'S' and 'E'. The 'S' and 'E' will also be separated by at least one wall ('#').You may assume that the maze exit is always reachable from the start point.
OutputFor each maze in the input, output on a single line the number of (not necessarily unique) squares that a person would visit (including the 'S' and 'E') for (in order) the left, right, and shortest paths, separated by a single space each. Movement from one square to another is only allowed in the horizontal or vertical direction; movement along the diagonals is not allowed.
Sample Input
2
8 8
########
#......#
#.####.#
#.####.#
#.####.#
#.####.#
#...#..#
#S#E####
9 5
#########
#.#.#.#.#
S.......E
#.#.#.#.#
#########

Sample Output
37 5 5
17 17 9
#include<stdio.h>
#include<string.h>
#include<queue>
#include<iostream>
using namespace std;

struct node
{
int x,y;
int step;
};
int n,m;
char map[50][50];
int vis[50][50];
int dir[4][2] = {{-1,0},{0,-1},{1,0},{0,1}};//上左下右顺时针;
queue <node> que;
int ans3;

int dfs(int sx,int sy, int ex, int ey, int d, int ans)
{
if(sx == ex && sy == ey)
return ans;
d = (d+1)%4;//左转;
while(map[sx+dir[d][0]][sy+dir[d][1]] == '#')
d = (d+3)%4;//当有墙的时候就右转直到没有墙;
return dfs(sx+dir[d][0],sy+dir[d][1],ex,ey,d,ans+1);
}

void bfs(int sx,int sy, int ex, int ey)
{
while(!que.empty())
que.pop();
memset(vis,0,sizeof(vis));

que.push((struct node){sx,sy,1});
vis[sx][sy] = 1;

while(!que.empty())
{
struct node u = que.front();
que.pop();
if(u.x == ex && u.y == ey)
{
ans3 = u.step;
return;
}
if(u.x-1 >= 1 && !vis[u.x-1][u.y] && map[u.x-1][u.y] != '#')
{
vis[u.x-1][u.y] = 1;
que.push((struct node){u.x-1,u.y,u.step+1});
}
if(u.x+1 <= n && !vis[u.x+1][u.y] && map[u.x+1][u.y]  != '#')
{
vis[u.x+1][u.y] = 1;
que.push((struct node){u.x+1,u.y,u.step+1});
}
if(u.y-1 >= 1&& !vis[u.x][u.y-1] && map[u.x][u.y-1] != '#')
{
vis[u.x][u.y-1] = 1;
que.push((struct node){u.x,u.y-1,u.step+1});
}
if(u.y+1 <= m && !vis[u.x][u.y+1] && map[u.x][u.y+1] != '#')
{
vis[u.x][u.y+1] = 1;
que.push((struct node){u.x,u.y+1,u.step+1});
}
}
}
int main()
{
int t;
int sx,sy,ex,ey;
scanf("%d",&t);
while(t--)
{
memset(map,'#',sizeof(map));//外面加一道墙,从s进去之后只有一条路可走;
scanf("%d %d",&m,&n);
for(int i = 1; i <= n; i++)
{
for(int j = 1; j <= m; j++)
{
cin>>map[i][j];
if(map[i][j] == 'S')
{
sx = i;
sy= j;
}
if(map[i][j] == 'E')
{
ex = i;
ey = j;
}
}
}
printf("%d %d ",dfs(sx,sy,ex,ey,1,1),dfs(ex,ey,sx,sy,1,1));
bfs(sx,sy,ex,ey);
printf("%d\n",ans3);
}
return 0;
}
View Code

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: