您的位置:首页 > 其它

UVa10055 Hashmat the Brave Warrior

2013-08-06 21:34 507 查看
Problem A
Hashmat the brave warrior

Input: standard input
Output: standard output
 

Hashmat is a brave warrior whowith his group of young soldiers moves from one place to another to fightagainst his opponents. Before fighting he just calculates onething, the difference between his soldier number and the opponent's soldiernumber. From this
difference he decides whether to fight or not. Hashmat'ssoldier number is never greater than his opponent.

Input

The input contains two integer numbers inevery line. These two numbers in each line denotes the number of soldiers inHashmat's army and his opponent's army or vice versa. The input numbers are notgreater than 2^32. Input is terminated by End of File.

 

Output

 For each line of input,print the difference of number of soldiers between Hashmat's army and hisopponent's army. Each output should be in seperate line.

 

Sample Input:

10 12

10 14

100 200

 

[b]Sample Output:[/b]

2

4

100

___________________________________________________________________________________
Shahriar Manzoor

16-12-2000

算是在UVa上做的第一道题,算两个数之间的绝对值,要注意的就是数据比较大要用long long类型。

#include <iostream>
using namespace std;

int main() {
long long x;
long long y;
while (cin >> x >> y) {
if (x > y)
cout << x-y << endl;
else
cout << y-x << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  uva 算法