您的位置:首页 > 编程语言 > Java开发

hdu 1075 What Are You Talking About(HashMap水过,可用字典树)

2013-08-06 12:14 441 查看


What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)

Total Submission(s): 10330    Accepted Submission(s): 3292


Problem Description

Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help
him?

 

Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains
two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single
line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new
word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single
string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

 

Output

In this problem, you have to output the translation of the history book.

 

Sample Input

START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i'm fiwo riwosf.
i fiiwj fnnvk!
END

 

Sample Output

hello, i'm from mars.
i like earth!

Hint
Huge input, scanf is recommended.

 

import java.util.HashMap;
import java.util.Scanner;

public class Main{//用HashMap水过,可以用字典树
public static void main(String[] args) {
Scanner input=new Scanner(System.in);
String s=input.next();
HashMap<String,String> map=new HashMap<String, String>();
while(!(s=input.next()).equals("END")){
String str=input.next();
map.put(str, s);
}
s=input.next();
String sss=input.nextLine();
while(true){
String s2=input.nextLine();
if(s2.equals("END"))
break;
boolean ok=true;
int x=0;
for(int i=0;i<s2.length();i++){
char a=s2.charAt(i);
if(a>='a'&&a<='z'){
if(ok){
x=i;
ok=false;
}
}
else{
if(ok==false){
String s1=s2.substring(x,i);
if(map.get(s1)!=null){
System.out.print(map.get(s1));
}
else
System.out.print(s1);
}
System.out.print(a);
ok=true;
}
}
System.out.println();
}

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  java HashMap 字典树 ACM