您的位置:首页 > 其它

POJ 1056 字典树

2013-08-05 23:20 387 查看
IMMEDIATE DECODABILITY

Description
An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a
set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:

A:01 B:10 C:0010 D:0000

but this one is not:

A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input
Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed
by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output
For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.
Sample Input
01
10
0010
0000
9
01
10
010
0000
9

Sample Output
Set 1 is immediately decodable
Set 2 is not immediately decodable
题意:其实就是简单的查找,看某个数据是不是其中某个的前缀。

字典树..

#include <iostream>
using namespace std;
char s[1111][111];
struct node
{
node *next[26];
int num;
node()//构造函数
{
memset(next,0,sizeof(next));
num=0;
}
};
node *root;
void build(char *s)//建树
{
node *p=root;
for(int i=0;i<strlen(s);i++)
{
if(p->next[s[i]-'0']==NULL)
p->next[s[i]-'0']=new node;
p=p->next[s[i]-'0'];
p->num++;
}
}
int findstr(char *s)//查找
{
node *p=root;
for(int i=0;i<strlen(s);i++)
{
if(p->next[s[i]-'0']!=NULL)
p=p->next[s[i]-'0'];
else
return 0;
}
return p->num;
}
int main()
{
int i,j,k=0,x=1;
while(~scanf("%s",s[k++]))
{
root=new node;
build(s[k-1]);
while(~scanf("%s",s[k++]))
{
if(s[k-1][0]=='9')break;
build(s[k-1]);
}
bool flag=true;
k--;
for(i=0;i<k;i++)
{
if(findstr(s[i])>1)//要扣除自己本身
{
flag=false;
break;
}
}
if(flag==true)
printf("Set %d is immediately decodable\n",x++);
else
printf("Set %d is not immediately decodable\n",x++);
k=0;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: