您的位置:首页 > 其它

hdu4405(概率DP)

2013-08-05 21:47 274 查看

Aeroplane chess

[b]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 755    Accepted Submission(s): 523
[/b]

[align=left]Problem Description[/align]
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are
1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is
no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.

 

[align=left]Input[/align]
There are multiple test cases.

Each test case contains several lines.

The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).

Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  

The input end with N=0, M=0.

 

[align=left]Output[/align]
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.

 

[align=left]Sample Input[/align]

2 0
8 3
2 4
4 5
7 8
0 0

 

[align=left]Sample Output[/align]

1.1667
2.3441

 

[align=left]Source[/align]
2012 ACM/ICPC Asia Regional Jinhua Online
 
本题要求从0到n的跳跃次数的数学期望,中间有航班的可以直接跳到。
本题是个典型的概率DP,需找到状态转移方程:
    1.若i点没有航班,则dp[i]=1/6*(dp[i+1]+dp[i+2]+dp[i+3]+dp[i+4]+dp[i+5]+dp[i+6])+1;
    2.若i点有航班,则状态转移方程为dp[i]=dp[j],j是该处航班的终点
首先我用的递归,结果超栈,后来写了非递归的。
 
#include<iostream>
#include<cstdio>
using namespace std;

int n,m;
int flight[100000+100];
double dp[100000+100];

/*
double Solve(int s)
{
if(s==n)return 0;
else if(s>n)return 0;
else if(dp[s]!=0)return dp[s];
else if(flight[s]!=-1)return dp[s]=Solve(flight[s]);
{
return dp[s]=1.0/6.0*(Solve(s+1)+Solve(s+2)+Solve(s+3)+Solve(s+4)+Solve(s+5)+Solve(s+6))+1;
}
}
*/

int main()
{
int a,b,i,j;
double tmp;
while(~scanf("%d%d",&n,&m))
{
if(0==n&&0==m)
break;
//	memset(dp,0,sizeof(dp));
memset(flight,-1,sizeof(flight));
for(i=0;i<m;i++)
{
scanf("%d%d",&a,&b);
flight[a]=b;
}
dp
=0.0;
for(i=n-1;i>=0;i--)
{
if(flight[i]!=-1)
dp[i]=dp[flight[i]];
else
{
dp[i]=0.0;
for(j=1;j<=6;j++)
{
if(i+j<=n)
tmp=(dp[i+j]+1)/6.0;
else tmp=1.0/6.0;
dp[i]+=tmp;
}
}
}
printf("%.4lf\n",dp[0]);
//	printf("%.04lf\n",Solve(0));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  动态规划