您的位置:首页 > 其它

poj 1068 Parencodings (模拟)

2013-08-05 19:01 375 查看
Parencodings

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 17169Accepted: 10296
Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).

q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

S		(((()()())))

P-sequence	    4 5 6666

W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source

Tehran 2001

题意:

对于给出的原括号串,存在两种数字密码串:

1.p序列:当出现匹配括号对时,从该括号对的右括号开始往左数,直到最前面的左括号数,就是pi的值。

2.w序列:当出现匹配括号对时,包含在该括号对中的所有右括号数(包括该括号对),就是wi的值。

题目的要求:对给出的p数字串,求出对应的s串。串长均<=20.

提示:在处理括号序列时可以使用一个小技巧,把括号序列转化为01序列,左0右1,处理时比较方便

代码:

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;

int p[30];
int w[30];
int s[100];

int main()
{
int t,n,i,j,k,q;
int sum1,sum2,head,rear,t1,t2,headw,rearw;
scanf("%d",&t);
while(t--)
{
sum1=0,sum2=0,head=0,rear=0;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d",&p[i]);
if(sum1<p[i])
{
for(j=0;j<p[i]-sum1;j++)
s[rear++]=0;
sum1=p[i];
}
s[rear++]=1;
sum2++;
}
rearw=headw=0;
while(head!=rear)
{
t1=0,t2=0;
if(s[head]==1)
{
t1++;
if(s[head-1]==0)
w[rearw++]=1;
else
{
t1++;
q=head-1;
while(t1!=t2)
{
q--;
if(s[q]==0)
t2++;
else
t1++;
}
w[rearw++]=t1;
}
head++;
}
else
head++;
}
for(k=0;k<rearw;k++)
printf("%d%c",w[k],k==rearw-1?'\n':' ');
}
return 0;
}


11924371

fukan

1068

Accepted

144K

0MS

C++

1426B

2013-08-05 16:19:34

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: