您的位置:首页 > 产品设计 > UI/UE

HDOJ 1005 Number Sequence

2013-08-05 16:53 363 查看


Number Sequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 83381 Accepted Submission(s): 19710



Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0


Sample Output

2
5没有理解为什么q[i]==q[j]&&q[i-1]==q[j-1] 可以过 q[i]==q[j]&&q[i+1]==q[j+1]不行#include <stdio.h>
#include <iostream>
using namespace std;
int main()
{
int q[60],i,j,a,b,n,pos=0,len=0;
while (scanf("%d%d%d",&a,&b,&n)&&a&&b&&n)
{
q[1]=1;
q[2]=1;
for (i=3; i<55; i++)
{
q[i]=(a*q[i-1]+b*q[i-2])%7;
for (j=2; j<=i; j++)
{
if (q[i]==q[j]&&q[i-1]==q[j-1])
{

len=i-j;//循环的长度
pos=j;//循环开始的地方
break;
}
}
}

if (n<len)
printf ("%d\n",q
);
else
printf ("%d\n",q[pos+(n-pos)%len]);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: