您的位置:首页 > 其它

HDU--1213 -- How Many Tables [水水的并查集]

2013-08-05 10:59 453 查看
 

How Many Tables

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 9284    Accepted Submission(s): 4568

Problem Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 
Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

 
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

 
Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

 Sample Output

2
4

 

Code:

 

和1232几乎一样啊有木有,只改了个数啊

 

#include"stdio.h"
int set[1001];

int search(int n)
{
while(set
!=n)
n = set
;
return set
;
}

void update(int a,int b)
{
if(search(a)!=search(b))
set[search(a)] = search(b);
}

int main()
{
int a,b,m,n,count;
int t,i;
scanf("%d",&t);
while(t--)
{
count=0;
scanf("%d%d",&n,&m);
for(i=1;i<=n;i++)
set[i] = i;
while(m--)
{
scanf("%d%d",&a,&b);
update(a,b);
}
for(i=1;i<=n;i++)
if(set[i]==i) count++;
printf("%d\n",count);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: