您的位置:首页 > 其它

POJ 1961-Period:KMP

2013-08-04 15:42 411 查看
点击打开链接

Period

Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 11163 Accepted: 5162
Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is
one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 

number zero on it.
Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing
order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0

Sample Output
Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4


刚开始学习kmp,一知半解迷迷糊糊的就AC了,今天还有别的事情,就不再深究了,有时间再找几个KMP算法的题吧:

其实就是用了一个kmp算法中求next的函数,然后循环一遍字符串,每次求一下next的位置,看看是不是能构成循环

求next的算法可以看成一个动规

#include<stdio.h>
#include<string.h>
#define MAX 1000001
char str[MAX];
int next[MAX] = {-1};
void kmp_init(char *str, int* next)
{
int i, j;
int p = -1;
i = 0;
while(str[i])
{
if(p == -1 || str[i] == str[p])
next[++i] = ++p;
else
p = next[p];
}
}
int main()
{
// freopen("in.txt", "r", stdin);
int n;
int i = 1;
while(scanf("%d", &n), n != 0)
{
next[0] = -1;
scanf("%s", str);
printf("Test case #%d\n", i);
i++;
kmp_init(str, next);
int i;
int len = strlen(str);
for(i = 1; i <= len ; i++)
{
int j = i - next[i];
if(i != j && i % j == 0)
printf("%d %d\n", i , i / j);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: