您的位置:首页 > 其它

1053. Path of Equal Weight (30)-PAT

2013-08-03 21:45 567 查看


1053. Path of Equal Weight (30)

时间限制

10 ms

内存限制

32000 kB

代码长度限制

16000 B

判题程序

Standard

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes
along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower
number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.



Figure 1

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains
N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]


where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of
the line.

Note: sequence {A1, A2, ..., An} is said to be greater than sequence {B1, B2,
..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bifor i=1, ... k, and Ak+1 > Bk+1.
Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

推荐指数:※※

来源:http://pat.zju.edu.cn/contests/pat-a-practise/1053

树的深度遍历

#include<iostream>
#include<queue>
#include<vector>
#include<utility>
#include<string.h>
using namespace std;
#define  N 101
vector< int > edge[101];
vector<int> path;
int  nodes,no_leafs,s,*weight;
bool *visited;
bool  dfs(int curr,int curr_node){
int i;
curr+=weight[curr_node];
if(curr>s){
return false;
}
else if(curr==s&&edge[curr_node].size()==0){
path.push_back(weight[curr_node]);
cout<<path[0];
for(i=1;i<path.size();i++)
cout<<" "<<path[i];
cout<<endl;
path.pop_back();
}
else if(curr<s&&edge[curr_node].size()>0){
int max_w,max_id;
path.push_back(weight[curr_node]);
do{
max_w=-1;
max_id=-1;
for(i=0;i<edge[curr_node].size();i++){
if(visited[edge[curr_node][i]]==false&&weight[edge[curr_node][i]]>max_w){
max_w=weight[edge[curr_node][i]];
max_id=edge[curr_node][i];
}
}
if(max_id!=-1){//handle its max node which is not visisted
visited[max_id]=true;
dfs(curr,max_id);
}
}while(max_id!=-1);
visited[curr_node]=true;//current node is handle ok
path.pop_back();
}
return true;
}
int main()
{
int i,j;
cin>>nodes>>no_leafs>>s;
weight=new int[nodes];
visited=new bool[nodes];
for(i=0;i<nodes;i++)
cin>>weight[i];
for(i=0;i<no_leafs;i++){
int tmp_node,k,tmp_edge;
cin>>tmp_node>>k;
for(j=0;j<k;j++){
cin>>tmp_edge;
edge[tmp_node].push_back(tmp_edge);
}
}
memset(visited,0,nodes*sizeof(bool));
dfs(0,0);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: