您的位置:首页 > 其它

hdoj1075 What Are You Talking About

2013-08-02 13:41 453 查看

What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 102400/204800 K (Java/Others)
Total Submission(s): 10226 Accepted Submission(s): 3238


[align=left]Problem Description[/align]
Ignatius
is so lucky that he met a Martian yesterday. But he didn't know the
language the Martians use. The Martian gives him a history book of Mars
and a dictionary when it leaves. Now Ignatius want to translate the
history book into English. Can you help him?

[align=left]Input[/align]
The
problem has only one test case, the test case consists of two parts,
the dictionary part and the book part. The dictionary part starts with a
single line contains a string "START", this string should be ignored,
then some lines follow, each line contains two strings, the first one is
a word in English, the second one is the corresponding word in
Martian's language. A line with a single string "END" indicates the end
of the directory part, and this string should be ignored. The book part
starts with a single line contains a string "START", this string should
be ignored, then an article written in Martian's language. You should
translate the article into English with the dictionary. If you find the
word in the dictionary you should translate it and write the new word
into your translation, if you can't find the word in the dictionary you
do not have to translate it, and just copy the old word to your
translation. Space(' '), tab('\t'), enter('\n') and all the punctuation
should not be translated. A line with a single string "END" indicates
the end of the book part, and that's also the end of the input. All the
words are in the lowercase, and each word will contain at most 10
characters, and each line will contain at most 3000 characters.

[align=left]Output[/align]
In this problem, you have to output the translation of the history book.

[align=left]Sample Input[/align]

START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i'm fiwo riwosf.
i fiiwj fnnvk!

END

[align=left]Sample Output[/align]
hello, i'm from mars.
i like earth!

讲解:我用map容器写的嘎嘎 ,写了两天,累死我了,但可喜的是,AC了

#pragma warning(disable:4786)
#include<iostream>
#include<string>
#include<cstring>
#include<map>
using namespace std;
map<string,string>m;
map< string , string >::iterator it;
void fuu(char a[])
{
it = m.find(a) ;

if( it != m.end() )
cout<<it->second;
else cout<<a;
}
void fun(char mm[])
{
char s[10];
int i,nn=0;
int x=strlen(mm);
for(i=0; i<x; i++)
{
if(mm[i]!=' ' &&  mm[i]>='a' && mm[i]<='z')//把所有字符串中的单词转化成单个的单词,然后再map容器中寻找
{
s[nn++]=mm[i];
if(i==x-2)
{
s[nn]='\0';
fuu(s);
cout<<mm[x-1];
break;
}
}
else if(mm[i]==' ' || (mm[i]<'a' || mm[i]>'z'))
{
s[nn]='\0';
if(nn>0)
fuu(s);
nn=0;
cout<<mm[i];
}
}
return ;
}
int main()
{
//    freopen("Out.txt","w",stdout);
int len;
char a[11],b[11],mm[3010],ch[11];
cin>>ch;
while(1)
{
cin>>a>>b;
len=strlen(a);
if(len==3 && a[0]=='E' && a[1]=='N' && a[2]=='D')
break;
m[b]=a;
}
int i=0;
while(1)
{
gets(mm);
len=strlen(mm);
if(len==3 && mm[0]=='E' && mm[1]=='N' && mm[2]=='D')
{
break;
}
fun(mm);
if(i>0)
cout<<endl;//格式错了调了一个小时啊,最后才在这加了一个
i++;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: