您的位置:首页 > 其它

HDU 1002 大数

2013-08-02 12:42 302 查看

A + B Problem II

[align=left]Problem Description[/align]
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should
not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the
equation. Output a blank line between two test cases.

[align=left]Sample Input[/align]

2
1 2
112233445566778899 998877665544332211


[align=left]Sample Output[/align]

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110


#include <iostream>
using namespace std;
int main()
{
char s1[1111],s2[1111];
int n1,n2,n,A[1111],t,j;
scanf("%d",&t);
for(j=1;j<=t;j++)
{
if(j>1)printf("\n");
scanf("%s%s",&s1,&s2);
n1=strlen(s1),n2=strlen(s2);
n=n1>n2?n1:n2;
memset(A,0,sizeof(A));
int k=0,i;
for(i=0;i<n;i++)//个位数相加
{
n1--;n2--;
if(n1>=0&&n2>=0)
A[k++]=s1[n1]+s2[n2]-2*'0';
else if(n1>=0&&n2<0)
A[k++]=s1[n1]-'0';
else if(n1<0&&n2>=0)
A[k++]=s2[n2]-'0';
}
for(i=0;i<k-1;i++)//进位
if(A[i]>9)A[i+1]++,A[i]%=10;
for(i=k-1;i>0;i--)//去除前面为0的
if(A[i])break;
k=i;
printf("Case %d:\n%s + %s = ",j,s1,s2);
for(i=k;i>=0;i--)printf("%d",A[i]);
printf("\n");
}
return 0;
}


以前做的:
#include<stdio.h>
#include<string.h>
int main()
{
char a[1001],b[1001];
int  i,j,t,k=0;
scanf("%d",&t);
while(t--)
{
if(k>0)
puts("");
k++;
int A[1001]={0},B[1001]={0};
scanf("%s%s",a,b);
int x=strlen(a),y=strlen(b);
for(i=0;i<x;i++)
A[i]=a[x-1-i]-'0';
for(i=0;i<y;i++)
B[i]=b[y-1-i]-'0';
int c=0;
for(i=0;i<1001;i++)
{
int s=(A[i]+B[i]+c);
A[i]=s%10;
c=s/10;
}
printf("Case %d:\n%s + %s = ",k,a,b);
for( i=1001-1;i>=0;i--)
if(A[i])
break;
for(j=i;j>=0;j--)
printf("%d",A[j]);
puts("");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: