您的位置:首页 > 其它

POJ 2181 Jumping Cows

2013-08-01 21:52 337 查看
[b]Jumping Cows[/b]

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 6398Accepted: 3828
Description

Farmer John's cows would like to jump over the moon, just like the cows in their favorite nursery rhyme. Unfortunately, cows can not jump.

The local witch doctor has mixed up P (1 <= P <= 150,000) potions to aid the cows in their quest to jump. These potions must be administered exactly in the order they were created, though some may be skipped.

Each potion has a 'strength' (1 <= strength <= 500) that enhances the cows' jumping ability. Taking a potion during an odd time step increases the cows' jump; taking a potion during an even time step decreases the jump. Before taking any potions the cows' jumping ability is, of course, 0.

No potion can be taken twice, and once the cow has begun taking potions, one potion must be taken during each time step, starting at time 1. One or more potions may be skipped in each turn.

Determine which potions to take to get the highest jump.
Input

* Line 1: A single integer, P

* Lines 2..P+1: Each line contains a single integer that is the strength of a potion. Line 2 gives the strength of the first potion; line 3 gives the strength of the second potion; and so on.
Output

* Line 1: A single integer that is the maximum possible jump.
Sample Input

8
7
2
1
8
4
3
5
6

Sample Output

17
题目大意:从一列数字中按照编号从小到大有选择的取数,若取到的数字的为第奇数个则加上该数,否则减去该数,问取到的数的最大总和。
解题方法:动态规划,dp[i][0] = max(dp[i - 1][0], dp[i - 1][1] + num[i])表示当前取的是第奇数个,dp[i][1] = max(dp[i - 1][1], dp[i - 1][0] - num[i])表示当前取的是第偶数个。


#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;

int num[150010];
int dp[150010][2];

int main()
{
int n;
scanf("%d", &n);
for (int i = 1; i <= n; i++)
{
scanf("%d", &num[i]);
}
for (int i = 1; i <= n; i++)
{
dp[i][0] = max(dp[i - 1][0], dp[i - 1][1] + num[i]);
dp[i][1] = max(dp[i - 1][1], dp[i - 1][0] - num[i]);
}
printf("%d\n", max(dp
[0], dp
[1]));
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: