您的位置:首页 > 其它

HDU 4642 Fliping game

2013-08-01 20:32 281 查看


Fliping game

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 237 Accepted Submission(s): 168



Problem Description

Alice and Bob are playing a kind of special game on an N*M board (N rows, M columns). At the beginning, there are N*M coins in this board with one in each grid and every coin may be upward or downward freely. Then they take turns to choose a rectangle (x1,
y1)-(n, m) (1 ≤ x1≤n, 1≤y1≤m) and flips all the coins (upward to downward, downward to upward) in it (i.e. flip all positions (x, y) where x1≤x≤n, y1≤y≤m)). The only restriction is that the top-left corner
(i.e. (x1, y1)) must be changing from upward to downward. The game ends when all coins are downward, and the one who cannot play in his (her) turns loses the game. Here's the problem: Who will win the game if both use the best strategy?
You can assume that Alice always goes first.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case starts with two integers N and M indicate the size of the board. Then goes N line, each line with M integers shows the state of each coin, 1<=N,M<=100. 0 means that this coin is downward in the initial, 1 means that this coin
is upward in the initial.

Output

For each case, output the winner’s name, either Alice or Bob.

Sample Input

2
2 2
1 1
1 1
3 3
0 0 0
0 0 0
0 0 0


Sample Output

Alice
Bob


Source

2013 Multi-University Training Contest 4

Recommend

zhuyuanchen520

题意: 略。

思路:
最后一个格子是会被任意格子影响的。
每次只要保证自己取完后, 最后一个格子是0, 就不会输。
因为: 对于后者如果还能取,最后一个格子肯定会变成1, 那么自己就还能取。 如果后者已经没得取了, 那么自己就已经赢了。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <vector>
using namespace std;

//

const int V = 1000 + 50;
const int MaxN = 80 + 5;
const int mod = 10000 + 7;
int T, n, m;
int main() {
int i, j;
scanf("%d", &T);
while(T--) {
int temp;
scanf("%d%d", &n, &m);
for(i = 0; i < n; ++i)
for(j = 0; j < m; ++j)
scanf("%d", &temp);
if(temp == 1)
printf("Alice\n");
else
printf("Bob\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: