您的位置:首页 > 其它

LA 4043 - Ants 求完美匹配

2013-08-01 15:53 363 查看
点击打开链接
 
 

4043 - Ants

Time limit: 3.000 seconds
 
Young naturalist Bill studies ants in school. His ants feed on plant-louses that live on apple trees. Each ant colony needs its own apple tree to feed itself.

Bill has a map with coordinates of n ant colonies and
n apple trees. He knows that ants travel from their colony to their feeding places and back using chemically tagged routes. The routes cannot intersect each other or ants will get confused and get to the wrong colony or tree,
thus spurring a war between colonies.

Bill would like to connect each ant colony to a single apple tree so that all
n routes are non-intersecting straight lines. In this problem such connection is always possible. Your task is to write a program that finds such connection.



On this picture ant colonies are denoted by empty circles and apple trees are denoted by filled circles. One possible connection is denoted by lines.

Input 

Input has several dataset. The first line of each dataset contains a single integer number
n (1

n

100)
-- the number of ant colonies and apple trees. It is followed by
n lines describing n ant colonies, followed by
n lines describing n apple trees. Each ant colony and apple tree is described by a pair of integer coordinates
x and y
(- 10000

x,
y

10000) on a Cartesian plane. All ant colonies and apple trees occupy distinct points on a plane. No three points
are on the same line.

Output 

For each dataset, write to the output file n lines with one integer number on each line. The number written on
i -th line denotes the number (from 1 to
n ) of the apple tree that is connected to the
i i-th ant colony. Print a blank line between datasets.

Sample Input 

5
-42 58
44 86
7 28
99 34
-13 -59
-47 -44
86 74
68 -75
-68 60
99 -60


Sample Output 

4
2
1
5
3


 

 

题意:给出n个白点和黑点的坐标,要求用n条不相交的线段将它们连接在一起,其中每条线段恰好连接一个白点和一个黑点,每个点恰好连接到一条线段。求第i个白点所连接的黑点编号。

构造一个二分图,每个白点对应一个X节点,每个黑点对应一个Y结点,每个黑点和白点相连,权值等于它们的距离。最佳完美匹配就是它的解。

 
 
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define inf 0x7fffffff
using namespace std;
int n;
double g[117][117],lx[117],ly[117];
int match[117];
bool visx[117],visy[117];
double wx[117],wy[117],bx[117],by[117];

bool dfs(int cur)
{
visx[cur]=true;
for(int y=1; y<=n; y++)
{
int t=lx[cur]+ly[y]-g[cur][y];
if(t==0&&!visy[y])
{
visy[y]=true;
if(!match[y]||dfs(match[y]))
{
match[y]=cur;
return true;
}
}
}
return false;
}

void update()
{
double d=inf;
for(int i=1; i<=n; i++)
{
if(visx[i])
for(int j=1; j<=n; j++)
if(!visy[j])
d=min(d,lx[i]+ly[j]-g[i][j]);
}
for(int i=1; i<=n; i++)
{
if(visx[i])lx[i]-=d;
if(visy[i])ly[i]+=d;
}
}
void KM()
{
for(int i=1; i<=n; i++)
{
lx[i]=ly[i]=match[i]=0;
for(int j=1; j<=n; j++)
{
lx[i]=max(lx[i],g[i][j]);
}
}
for(int x=1; x<=n; x++)
{
while(true)
{
for(int j=1;j<=n;j++)visx[j]=visy[j]=false;
if(dfs(x))break;
else update();
}
}
}
int main()
{
bool first=false;
while(scanf("%d",&n)!=EOF)
{
if(first)printf("\n");
first=true;
for(int i=1; i<=n; i++)
{
scanf("%lf%lf",&wx[i],&wy[i]);
}
for(int i=1; i<=n; i++)
{
scanf("%lf%lf",&bx[i],&by[i]);
}
for(int i=1; i<=n; i++)
for(int j=1; j<=n; j++)
{
g[j][i]=-sqrt((wx[i]-bx[j])*(wx[i]-bx[j])+(wy[i]-by[j])*(wy[i]-by[j]));
}
KM();
for(int i=1; i<=n; i++)
printf("%d\n",match[i]);
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: