您的位置:首页 > 其它

hdu 1856 More is better(并查集)

2013-08-01 15:24 387 查看
Problem Description

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are
still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

 

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

 

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 

 

Sample Input

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

 

Sample Output

4
2

Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect),
then A and C are also friends(indirect).

In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

 
题解:
      并查集的一般题,但是也花了好长时间改错和优化,在查的时候,look(n)要使用递归代替while循环,否则会TLE,所以TLE了好几次。
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;
int root[10000010],sum[10000010],Max=0;
int look(int n)
{
if(n!=root
)
root
=look(root
);     //使用递归代替while,否则会TLE
return root
;
}

void _union(int a,int b)
{
a=look(a);
b=look(b);
if(a!=b)  {root[a]=b;sum[b]+=sum[a];}   //在这折腾了好长时间,竟然忘记加括号,WA了好几次  TAT
if(Max<sum[b])  Max=sum[b];
}
int main()
{
int n,x,y,i;
while(scanf("%d",&n)!=EOF)
{

for(i=0;i<=10000000;i++)
{
root[i]=i;sum[i]=1;
}
Max=1;
for(i=1;i<=n;i++)
{
scanf("%d%d",&x,&y);
_union(x,y);

}

printf("%d\n",Max);

}

return 0;
}


    
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: