您的位置:首页 > 产品设计 > UI/UE

hdu 1159 Common Subsequence

2013-08-01 10:34 288 查看

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 17499    Accepted Submission(s): 7341


[align=left]Problem Description[/align]
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing
sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of
the maximum-length common subsequence of X and Y.

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard
output the length of the maximum-length common subsequence from the beginning of a separate line.

 

 

[align=left]Sample Input[/align]

abcfbc abfcab
programming contest
abcd mnp

 

 

[align=left]Sample Output[/align]

4
2
0

 

这道题要求最长公共子序列,两个字符串aa,bb。用dp[i][j]表示aa的前i个字符与bb前j个字符的最长公共子序列。

也就说 如果aa[i]与bb[j]相等,那么dp[i+1][j+1]=dp[i][j]+1 吧,否则dp[i+1][j+1]=max(dp(i+1,j),dp(i,j+1));

(如果不相等  dp就要等于 aa中的前i个字符bb的j+1个字符   或者 aa中的前i+1个字符bb中前几个字符  中的较大值)

 

 

#include<iostream>

#include<string>

using namespace std;

#define max 1001

int dp[max][max];

int main()

{

 string aa,bb;

 int la,lb,i,j;

 

 while(cin>>aa>>bb)

 {

  la=aa.length();

  lb=bb.length();

  

  for(i=0;i<la;i++)

  {

   for(j=0;j<lb;j++)

   {

    if(aa[i]==bb[j])

     dp[i+1][j+1]=dp[i][j]+1;

    else

     dp[i+1][j+1]= dp[i][j+1]>dp[i+1][j]?dp[i][j+1]:dp[i+1][j];//dp[0][1=] dp[1][0]=0

   }

  }

  cout<<dp[la][lb]<<endl;

 }

}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: