您的位置:首页 > 其它

uva 712 S-Trees(利用二叉树的特点)

2013-08-01 00:08 435 查看


 S-Trees 
A Strange Tree (S-tree) over the variable set 

 is a binary tree representing a Boolean function

.
Each path of the S-tree begins at the root node and consists of n+1 nodes. Each of the S-tree's nodes has adepth, which is the amount of nodes between itself and the root (so the root has depth 0). The nodes with depth less than n are
callednon-terminal nodes. All non-terminal nodes have two children: the right child and the left child. Each non-terminal node is marked with some variable xi from the variable set Xn.
All non-terminal nodes with the same depth are marked with the same variable, and non-terminal nodes with different depth are marked with different variables. So, there is a unique variable xi1 corresponding to the root,
a unique variable xi2 corresponding to the nodes with depth 1, and so on. The sequence of the variables 

 is
called the variable ordering. The nodes having depth n are called terminal nodes. They have no children and are marked with either 0 or 1. Note that the variable ordering and the distribution of 0's and 1's on terminal nodes are
sufficient to completely describe an S-tree.

As stated earlier, each S-tree represents a Boolean function f. If you have an S-tree and values for the variables 

,
then it is quite simple to find out what 

 is: start with the root. Now repeat the following: if the node you are
at is labelled with a variable xi, then depending on whether the value of the variable is 1 or 0, you go its right or left child, respectively. Once you reach a terminal node, its label gives the value of the function.



Figure 1: S-trees for the function 


On the picture, two S-trees representing the same Boolean function, 

, are shown. For the left
tree, the variable ordering is x1, x2, x3, and for the right tree it is x3, x1, x2.

The values of the variables 

, are given as a Variable Values Assignment (VVA) 



with 

.
For instance, ( x1 =
1, x2 =
1 x3 =
0) would be a valid VVA for n = 3, resulting
for the sample function above in the value 

.
The corresponding paths are shown bold in the picture.

Your task is to write a program which takes an S-tree and some VVAs and computes 

 as described above.


Input 

The input file contains the description of several S-trees with associated VVAs which you have to process. Each description begins with a line
containing a single integer n, 

,
the depth of the S-tree. This is followed by a line describing the variable ordering of the S-tree. The format of that line is xi1 xi2 ...xin.
(There will be exactly n different space-separated
strings). So, for n = 3 and the variable ordering x3, x1, x2,
this line would look as follows:

x3 x1 x2

In the next line the distribution of 0's and 1's over the terminal nodes is given. There will be exactly 2n characters (each of which can be 0 or 1), followed by the new-line character. The characters are given in the order in which they
appear in the S-tree, the first character corresponds to the leftmost terminal node of the S-tree, the last one to its rightmost terminal node.

The next line contains a single integer m, the number of VVAs, followed by m lines describing them. Each of the m lines contains exactly n characters (each of which can be 0 or 1), followed by a new-line character. Regardless
of the variable ordering of the S-tree, the first character always describes the value of x1, the second character describes the value of x2, and so on. So, the line

110

corresponds to the VVA ( x1 = 1, x2 = 1, x3 = 0).

The input is terminated by a test case starting with n = 0. This test case should not be processed.


Output 

For each S-tree, output the line ``S-Tree #j:",
where j is the number of the S-tree. Then print
a line that contains the value of

 for
each of the given m VVAs, where f is
the function defined by the S-tree.

Output a blank line after each test case.


Sample Input 

3
x1 x2 x3
00000111
4
000
010
111
110
3
x3 x1 x2
00010011
4
000
010
111
110
0



Sample Output 

S-Tree #1:
0011

S-Tree #2:
0011

题目大意:给一个序列集合{x1, x2, x3, ....,xn}, 集合中不是0就是1 , 然后有一个n层的树,集合的序列表示树的填充方向,(对应后面给出的指令)从跟结点出发, 如果那个结点是0,就往左儿子方向走, 如果是1就往右儿子方向走。 最后落在最后一层的叶子结点上,输出这个数字

解题思路:不用建树,碰到0就*2,碰到1就*2+1.

#include<stdio.h>
#include<string.h>
#include<math.h>
#define N 1000
#define M 10

int main(){
int t = 1, n, m;
char str
, tem[M], q[M];
int num[M];

while (scanf("%d", &n), n){
// Init.
memset(str, 0, sizeof(str));
memset(tem, 0, sizeof(tem));
memset(q, 0, sizeof(q));
memset(num, 0, sizeof(num));

// Read.
for (int i = 0; i < n; i++){
scanf("%s", tem);
num[i] = tem[1] - '0';
}
scanf("%s", str);
scanf("%d", &m);

// Handle.
int f = pow(2, n);
for (int i = 0; i < m; i++){
scanf("%s", tem);
int k = 1;
for (int j = 0; j < n; j++){
if (tem[num[j] - 1] == '1')
k = k * 2 + 1;
else
k = k * 2;
}
q[i] = str[k - f];
}
q[m] = '\0';
printf("S-Tree #%d:\n%s\n\n", t++, q);
}
return 0;}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: